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GoldMine Premium Edition

Version 9.2.0

Release Notes




Updated July 23, 2012


WHAT'S NEW IN GOLDMINE PREMIUM EDITION 9.2.0

GoldMine Premium Edition now supports Microsoft SQL Server 2012.

LinkedIn, Facebook, Twitter, and Google integrations are now provided through the GM+View tab.  New GM+View templates are provided to use these integrations:

	Facebook Profile shows the Facebook profile page for a contact
	Facebook Company Search shows Facebook pages matching a contact’s company 
	Facebook Contact Search shows Facebook profiles matching a contact’s name
	Google Company Search shows web search results for a contact’s name 
	Google Contact Search shows web search results for a contact’s company
	Google Directions shows directions to the contact’s address from the address registered for the GoldMine license, shown at Help > Update GoldMine > Registration
	Google Map shows a map of the contact’s address
	LinkedIn Profile shows the LinkedIn profile page for a contact
	LinkedIn Company Search shows LinkedIn pages matching a contact’s company
	LinkedIn Contact Search shows LinkedIn pages matching a contact’s name
	Twitter Company Search shows Tweets with keywords matching a contact’s company
	Twitter Contact Search shows Tweets with keywords matching a contact’s name
	Twitter Profile shows the contact’s Twitter timeline



An Import feature is now available at Web > Setup GM+View > Import to enable the new GM+View templates to be added to an existing installation.  These templates are available through Drivers and Downloads at www.frontrange.com/support.  After a template has been imported, it will be available to users through the GM+View tab.  If you do not see the GM+View tab under a contact record, go to Tools > Options > Record > Tabs and check “GM+View”.  Then open a contact and click the down-arrow button that is on the row of tabs beneath the fields area (see below), and select “GM+View”.
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When viewing the GM+View tab, you can select a template using the drop-down list shown in the upper right corner of the tab area.

During the upgrade, the following new fields are added to the GoldMine database:  UFACEBOOK, ULINKEDIN, and UTWITTER.  These fields track the corresponding identifiers for contacts using each of these services.  Administrators can add these fields to a contact fields view by right-clicking and selecting New Field, and then selecting one of these fields from the drop-down list.
	UFACEBOOK contains the Facebook username.  To find the Facebook username for a contact, view the contact’s profile page in Facebook and copy the text displayed in the browser’s address bar after “www.facebook.com/”
	ULINKEDIN contains the LinkedIn ID.  To find the LinkedIn ID for a contact, view the contact’s profile in LinkedIn and copy the number shown in the browser address bar after “id=”.
	UTWITTER contains the Twitter username, without the “@” symbol.  



WHAT'S ENHANCED IN GOLDMINE PREMIUM EDITION 9.2.0

The edit screens for scheduled and completed activities now include a button that that enables the user to see Notes displayed in a larger, resizable window.

GoldMine Plus for Microsoft Outlook now supports the use of a GoldMine database with a secondary contact set.

Outlook synchronization screens have been update to clarify the behavior when synchronizing activities within a date range and a contact filter or group.



WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.2.0

Note:  GoldMine Premium Edition 9.2.0 also provides the fixes and enhancements included with GoldMine Premium Edition 9.0.0, GoldMine Premium Edition 9.0.1, GoldMine Premium Edition 9.0.1 Hotfix 1, GoldMine Premium Edition 9.0.2, GoldMine Premium Edition 9.0.3, GoldMine Premium Edition 9.0.4, and GoldMine Premium Edition 9.0.4 Hotfix 1, listed below.


ID #
Issue Description
163595
When adding Site to GoldSync Site Group, Sites (Sub-licenses) are not ordered alphabetically
163593
Times are always shown in 24 hour format, regardless of local time format option 
163572
GoldMine License Manager does not order GoldSync Sites alphabetically
163361
JavaScript error appears when changing view in Outlook 
163291
If an Opportunity has a single associated pending Forecasted Sale, then update to Probability of one should automatically update Probability of other
162761
When NTLM authentication is selected, configuration screen incorrectly shows username and password fields
160828
E-mails with Base64 encoding are not displayed correctly when using Exchange
160473
Double-arrow button does not hide contact details when clicked
158960
To-do Reference column in Calendar week view does not show contact name
158956
Event date is not shown in Calendar week view
156623
GoldMine crashes upon launch via Terminal Services with KB2533623 installed on Windows Server 2008
154965
Body of e-mail is blank when auto-linking e-mail from Outlook 2010
154821
Performance issue in Outlook when there are many e-mail folders
152570
When performing a two-way sync with Outlook, calendar items linked to records with no contact name become unlinked in GoldMine and lose the company name in Outlook 
150704
Linked Document move fails for mailbox attachments outside root directory
145929
New e-mails that are auto-retrieved to the Inbox will not display until user scrolls the screen  
145920
Auto-retrieve in E-Mail Center reverts to default sort order by Date
145570
Merge and Edit will leave a copy of the template file in My Documents for the logged in user
145391
A field level conttlog is not created/updated if a user changes the data in the field but the lookup.ini instructions do not update the newly entered data.  
143641
The Synchronization tab does not display in the Setup GoldMine Plus options for non-master users
122581
Option to use a later Start Time is not respected when executing Automated Processes 
115324
Printing a document using a filter does not respect the sort order that is set in the filter
109845
Print merge order is inconsistent for large contact groups
108886
Export from Excel to GoldMine creates incorrect relationship trees



WHAT'S NEW IN GOLDMINE PREMIUM EDITION 9.0.4

GoldMine Premium Edition now supports GoldMine Mobile Edition 9.

A new Messaging tab appears in the user options screen when a GoldMine Mobile license is added to the License Manager.  The Messaging tab enables users to receive alarms for upcoming activities on their mobile devices as SMS messages.  For more information, please review the GoldMine Mobile Edition Installation and User Guide.  The Pager tab that appeared in previous releases is no longer displayed.


WHAT'S ENHANCED IN GOLDMINE PREMIUM EDITION 9.0.4

GoldMine Plus for Microsoft Outlook now includes an option to file Outlook e-mail messages in a specified GoldMine folder.  To use this option, go to Setup GoldMine Plus > Options and select the “As a completed activity in the filed e-mail folder” button and uncheck the “Fast File” option.
	If an e-mail message is instead linked as a pending activity, there will be a new File button active on the GoldMine pane in Outlook, enabling the message to be filed on demand.


To improve performance in the GoldMine E-mail editor, the “Regarding:” drop-down list (where the user can select an opportunity, project, or case) will only show 50 items related to the current contact.  If a larger list is necessary, the following entry can be added to the gm.ini file:
[GoldMine]
MaxRegardingListSize=n  (where n is the desired list size)


To support environments where there is no C:\ drive available, GoldMine Plus for Microsoft Outlook now has a setting that enables an administrator to choose where system log files are created.  If an alternate location is needed, add an entry to the gm.ini in the following format:
[GoldMine]
OutlookAddinLogDir=D:\GMOutlookLog\


The checkboxes used to set up automatic synchronization with Outlook have been modified to clarify their behavior.  To use automatic synchronization with Outlook, go to Tools > Synchronize > Synchronize with Outlook and check “Automatically synchronize with Outlook”.  
In addition, there is a secondary option, available at Tools > Configure > Outlook Integration Settings > Synchronization, which enables the synchronization schedule to be activated when Outlook is opened.  This option is now labeled “Use automatic synchronization when Outlook is open” and now can be enabled only if “Automatically synchronize with Outlook” is checked.


WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.4 HOTFIX 1

ID #
Issue Description
160293
E-mails sent via Merge process display merge codes instead of contact data
160291
E-mails sent via Automated Process with Merge For option set to Record Owner or Selected User will send from logged-in user instead of designated user
160023
E-mails sent via Automated Process display merge codes instead of contact data
158161
Non-master users can view and edit other’s private activities from the graphical calendar



WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.4

ID #
Issue Description
157716
Slow response when using “Name (additional)” search in Contact Search Center
157168
Checking one online e-mail account and switching to another online account in Windows 7 causes application error
156735
Selected filter is not respected when syncing contacts with Outlook
154752
Performance issue in Outlook integration when a lot of users are defined 
151318
Updates on time of activities do not synchronize from GoldMine to Outlook for contact records created via Outlook integration
150447
Moving a recurring activity in GoldMine, either the first occurrence or last occurrence deleted.
149476
E-mail attachments linked to GoldMine via Outlook will not sync from remote site 
149472
Option to start sync when starting Outlook does not work with Outlook 2010
149395
When changes are made in Outlook to contacts created in GoldMine and synced to Outlook, the changes are immediately seen in the GoldMine contact record with no option to Send contact data to GoldMine selected.
148878
On second sync, lookup.ini is sent from remote to server thus overwrites the file on the server
148863
Inconsistent sync of lookup.ini file
148043
Rollup doesn't work for Opportunities and Projects
148018
Performance issues when linking emails from Outlook to GoldMine
147616
Validation errors appear after erasing Target Close and Actual Close dates for opportunity
146775
Add to Contact Group in Search Center will add all contact records to the Group, if search result set is larger than max record setting, and user has paged down to load additional records
146561
Changes to Amount / Units when completing one instance of a recurring Forecasted Sale are not retained
146488
Clicking on e-mails with a null From: address causes Outlook to hang for 4 seconds, then not link the e-mail
146301
Default table of a GoldMine system will be overwritten when a user enters the table name when creating a new Leads Analysis table
145670
Updating a pending activity does not update the corresponding field in the contact summary tab
145572
Unlinked activity doesn't appear on user's calendar after editing the unlinked activity to add the specific user to the unlinked activity
145287
Inconsistency between the queries that are run, depending on which search box you use
145013
Bad data in transfer set causes sync retrieval to fail with unclear error message
144533
Roll-Over Activities will roll over to the next day for all recurring activities
138548
Screen divider between contact information and tabs will not change and remains static
136786
Universal Search - GO button disabled for non-master user
128853
Zip code reverts back to original selection after selecting another city or reverts to the first city
127074
Linking an Outlook e-mail before sending will cause a blank e-mail to display in Outlook Outbox
125211
Outlook navigation pane customizations are not retained after closing Outlook
118791
Slow performance when handling e-mails at a contact with a lots of opportunities for that contact 
114248
E-mail sent through Automated Process is always sent from logged-in user’s account and with history created for logged-in user
110016
Cannot use CTRL+V to paste data within web pages in GM+View tab
108005
Word documents merged from protected templates are blank after being linked to a contact record
107744
Notes not correctly converted into Notes tab when swapping additional contact
104482
Taskbar toolbar reappears on next GoldMine start after it was removed from Toolbar using customize feature



WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.3

ID #
Issue Description
150834
Performance issues moving from one message to another in Outlook when connected to GoldMine
133122
Service Center displays all records in the database if no filter is applied by the user (does not respect limits on System Settings > Display)
120811
GoldMine stops responding while e-mail messages are being queued
118791
Slow response when handling e-mails for a contact with a large number of opportunities
97707
Sorting on Age and Actual End columns (Projects) sorts as character values and not on their numerical or date values



WHAT'S ENHANCED IN GOLDMINE PREMIUM EDITION 9.0.2

Microsoft Windows 7 SP1 is now supported.

Microsoft Windows 2008 R2 SP1 is now supported.

Microsoft SQL Server 2008 R2 is now supported.

Microsoft SQL Server 2005 SP4 is now supported.

Windows Internet Explorer 9 (IE 9) is now supported.  Note:  When using IE 9, Word documents currently cannot be previewed inside GoldMine if there is another Word document open in your operating system.

There is a new option to control the preview of document templates within the Document Management Center.  Disabling the preview may increase application performance while working with templates and improve reliability when merging documents.  To use this option, check or uncheck “Show preview for documents” in the lower right pane in the Document Management Center.

Updates to user records can now be synchronized between sites, using a new option in the GoldSync Site Group Member Wizard.  To synchronize user records, expand the Customizations node on the Send Options screen by clicking the “+” sign, and then check the box for Users.


WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.2


ID #
Issue Description
146660
Sync process stalls at gathering completions/deletions for CALDEF and eventually fails
144943
Unlinked recurring activities for another user will sync to Outlook when syncing only My Calendar using filter or group
144651
Accented characters cause wrong contact to be returned from search of GoldMine Address Book in Outlook
144554
Activity created in Outlook, recurring on a particular day of every month, creates large number of calendar items when synchronized to GoldMine
144317
GoldMine crashes when using the scroll bar while composing an e-mail message with IE 9 installed
143862
E-mail message is sent to wrong address if recipient’s address is added as new address via the select e-mail window and several e-mail addresses for the contact are available
143817
Outlook e-mail messages are not linked to GoldMine when NOCOUNT setting is applied in SQL Server 
143322
Undocked user cannot access the One-Button Sync tab to import a One-Button Sync Profile sent through Outlook, if there is no existing One-Button Sync Profile for the user
143281
E-mails retrieved at remote location are not shown in E-mail Center at server when using year/month folder structure in synchronizing across time zones
143152
Wrong Opportunity opened for editing in Opportunity Manager when column filter is active
142090
Error message appears when merging a Word template in the Document Management Center after launching Word followed by Excel
141549
Error in building transfer set for database with name ending in letter C
140561
On Windows 7, an attachment will be linked incorrectly after attempting to move it, and then canceling after receiving notification that the file already exists on the destination
140244
The 'Create Forecasted Sale' button in Opportunity Properties is grayed out
139784
Linking HTML e-mails from Outlook corrupts certain characters when the e-mail uses Western European encoding 
139181
Assigning a report to an Automated process Print Report event does not save the correct report
139169
Outlook Add-in shows as 'disabled' and cannot be enabled
138821
Custom toolbar item to Merge Tagged Records improperly merges records if toolbar button is clicked while no records are tagged
138528
Case number is not listed on e-mail notifications when reassigning a case 
138815
JavaScript code removed after editing GM+View template
137913
E-mails using UTF-8 subject lines are corrupted
137407
Resolving a case will replace the name of the linked contact with the contact displayed on the contact tab
136765
Single user-defined field is not being imported during WebImport
136763
WebImport unable to populate user-defined fields when NewRecord section of lookup.ini updates a user-defined field
136705
Time Stamp Format setting is not saved to service center mask customizations
135999
E-mail message manually linked from Sent folder in Outlook is displayed as an inbound message on the History tab
135983
On a server OS, dashboard checkboxes and radio buttons are not displayed
135555
When using a database that does not include a LEADDIST, LEADFILE, or SYNCLOCK table, clicking the “Read GoldMine Settings” button in Outlook produces an incorrect error message.
135545
The "Enable Outlook Sync" option under Tools > Users Settings > Properties > Outlook does not synchronize from the server to undocked machines
132578
Multi-contact activity is deleted for all contacts when attempting to delete a contact-specific instance from the calendar
132456
When editing an AP event that prints an envelope template, the template selection is corrupted (reset to the first item in the list)
130823
Relationship tab does not refresh properly when expanding a section
129836
New detail record includes copied CONTSUPP header data for column position from an extended detail
128853
Zip code reverts back to original selection after selecting another city or reverts to the first city
128841
If a field is accidently duplicated in a System View, it cannot be removed
128584
When using IMAP, e-mail sent via mobile device links from Sent folder in Outlook to contact record with sender’s e-mail address
127909
Cursor focus goes to the subject line instead of the e-mail body when replying or forwarding
126359
Tab order positions are not being respected when creating new GoldMine contacts, skipping ZIP
124508
Daily DayTimer Summary report only shows times with activities scheduled
124394
Contact information in the history record is for the customer viewed in the Contacts tab
122618
Sort works inconsistently in Task area of Activity List
119811
Print Pages action in e-mail reading window does not provide option to print selected text within message
119647
When exporting contacts from a large database using a filter based on Contact2 fields, there is a long delay between the Select Filter/Group screen and the Field Mappings screen
111851
Customized labels are not shown in project window
108957
Case History tab shows no data after upgrading from version 8.0 with customized case tabs
108891
Wrong activities displayed after activating rollup on Relationship tab, selecting History or Pending tab, and clicking column header to sort results
108648
Private Activities are not visible for other users in Calendar
108579
Completing an activity for a selected contact will cause active contact to refresh to the contact on calendar when Calendar is in Outline view with an activity scheduled for current date selected and Sync Contact enabled 
107197
“Pop-up when selected” option causes F2 lookup screen to be intrusive in the contact search center when clicking on different tabs and clicking back to CSC
101909
When scrolling between cases, the notes from the last case are displayed
70271
Time column does not sort properly when used for priority



WHAT'S ENHANCED IN GOLDMINE PREMIUM EDITION 9.0.1

GoldMine Premium Edition now supports Microsoft Office 2010 (32-bit version).  

GoldMine now can access Windows certificate stores to authenticate digitally signed e-mail messages.  This option is available via Tools > Options > E-mail > More Options > Security > Digital IDs > Trusted Certificate Authorities > Import.

Users can now minimize the details pane that shows fields in the Opportunity Manager, Project Manager, and Service Center.


WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.1 HOTFIX 1

ID #
Issue Description
142555
Error message appears when opening Outlook calendar if forecasted sales are displayed in Outlook, and there is a forecasted sale related to a contact with a null value in contact field 
141004
GoldMine toolbar does not appear in Outlook when using Terminal Services
140515
Outlook sync profile does not retain contact group setting if the contact group has a RecID value ending in a space
140055
When synchronizing with Outlook using a contact group or filter, other users’ linked recurring activities are synchronized to Outlook
139816
Paging of contact records in the Contact Search Center can cause entire database to be selected for different workflow operations
139579
Memory leak in Outlook.exe process
139196
Performance issues in Outlook add-in
139171
AddinExpress error message appears in Outlook
139163
Object Reference error when reading GoldMine settings from Outlook
139041
Object reference error in Outlook when no record types are set up in GoldMine
138584
GoldMine creates Accountno values with less than 20 characters when the contact name is abbreviated as first initial with a dot
137333
When sorting opportunities by actual close date, the sort is not chronological
137160
Activities synchronized from Outlook produce one alarm per attendee in GoldMine
136244
When editing an activity, the Opportunity/Project selection is not available if the Accountno for the corresponding contact contains less than 20 characters 
128699
E-mail filed on the remote is not filed on the server after sync
126594
When entering an address for additional contacts, the Zip field does not auto-complete as expected



WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.1


ID #
Issue Description
132899
Error message when opening Outlook folder from GoldMine E-mail Center on Windows 7
132294
Cannot add note from Outlook when using non-US regional settings
129817
ADO Error shown in Event Viewer after deleting e-mail message and synchronizing
129243
When multiple calendar tabs are open with activities selected, the contact record tab may oscillate between contacts
128879
Mail Merge fails when using a template that is active in preview pane in Links tab
128466
Localized characters corrupted when using Quote text on Plain text emails
127510
Non-master users cannot see closed opportunities managed by other users on the contact record's Opportunity tab
127504
Application error when retrieving transfer set with change to field label shown on active primary fields view while Contact Search Center is open
127503
Contact record focus changes when sync session ends
127086
Intermittent application errors when user retrieves meeting request
126946
Misspelling in Dashboard: ‘defenition’ instead of ‘definition’
126689
Dialog text does not indicate that you can enter a company name when searching for a contact to link an Outlook e-mail
126588
Exception when saving GoldMine settings in Outlook
126515
When creating a forecasted sale, the product field is truncated to 20 Characters
126133
Line breaks are doubled in e-mails linked from Outlook on Windows 7
125818
Cannot use custom field labels in Opportunity Manager 
125614
Report does not return results when using active contact filter and contact set is not the main one for the database
125287
Forecast Dashboard produces error when Windows regional settings are set to use comma as decimal symbol and period as digit grouping symbol
124901
Outlook sync does not automatically restart when GoldMine is launched and Outlook sync has been running in silent mode even with Automatically synchronize with Outlook option turned on
124807
Database operation error occurs after changing an option and selecting (All Users) in Outlook Integration Settings
124658
Stop Timer action causes timer to be removed from status bar
124173
Linking via Outlook corrupts special characters when e-mail uses UTF-8 encoding
123440
Auto-linking does not work for e-mails received into non-default Outlook inbox on Vista
123394
Universal Search for e-mail does not return correct results in Windows 7 
123267
After scheduling an activity with a primary contact, edit to replace the primary contact with an additional contact is not saved
123263
Send E-mail option in Additional Contacts tab opens GoldMine compose window even if Outlook is the default e-mail client
123221
E-mail link produces two prompts for an e-mail address when there are multiple e-mail addresses related to the contact and Outlook is used for linked e-mail addresses in GoldMine
122554
Error message is generated after clicking on New >> Opportunity or New >> Project in E-mail message window without manually linking a contact
122480
Opportunities in which contact is a team member are unavailable for linking from Outlook
122475
Up/Down buttons are missing in Column Selection tab of Select Browser Columns window in Contact Search Center
122229
Macro data is not merged when applying an e-mail template in Outlook
121836
Performance issue when selecting a Recently Viewed contact with a lot of history or pending activities 
121631
Application error when closing GoldMine with Script tab open in tabbed view or in custom view
121464
When using Windows 2008 R2 Remote Desktop Services, GoldMine may hang when user scrolls rapidly through e-mail messages with images
120744
Contact2 macro within e-mail template displays the macro when field data is unavailable
120379
Comodo Digital Signature not valid in GoldMine
119945
Sporadic application errors when sending e-mails
118323
Cannot change the label display for user-defined fields in Opportunities
118303
From: e-mail address is truncated when replying to an e-mail sent from Outlook with Exchange 2007
118152
Error when using Lookup Wizard for query based on field value and history in selected date range
117069
Removing a user from one group may cause it to be removed from other user groups
117048
Internal GoldMine e-mails are not visible in E-mail Center until Refresh button is pressed 
116650
When opportunity manager is not open, clicking on the opportunity link from Regarding column in task folder in activity list navigates to wrong opportunity
115314
Error message when attempting to open e-mails from the online folder after disconnecting from server
114430
Google Analytics scripts cause error when an e-mail containing them is viewed in the History tab with the preview pane open
114391
Converting additional contact does not carry over the additional contact's notes
114244
Private activates are not indicated on Free/Busy tab for non-master users
113411
Auto link of an Excel .xls template will link the template, not the merged document
112404
After changes are made to the System tab in user options, notes are set to use plain text
109213
“Assertion Failed” message appears sporadically when using GoldMine E-mail center 
108606
Intermittent application error when forwarding e-mail message
107643
E-mail preview stops working when headers are downloading and user toggles between inbox and online
107496
Can't right-click and 'file to' a custom filed folder in the E-mail center if there are 51+ folders
107232
When GoldMine is open on the links tab, and an Excel file is in the preview, user is unable to open Excel document
107212
Pressing a key while viewing Inbox does not take you to section of messages beginning with associated key
106374
JavaScript in E-mail causes GoldMine to hang when viewing the History tab with the preview window active
104757
'Remember lookup by' option does not retain 'contact (primary and additional)' selection after closing contact search center
104596
Workstation still launches previous version of GoldMine after upgrade process is canceled
104074
Change of E-mail list and Preview splitter is not retained after navigating away from E-mail Center
103994
Pressing a key while viewing Inbox does not take you to section of messages beginning with associated key
102393
Activity list focus does not move to the next item in list after completing an activity
102310
Getting a Digital Signature Verification Failure from military sender
100992
Keyboard shortcut to search for sender does not work in the E-mail Center
100046
E-mails sent from Newfoundland are being received 2.5 hours earlier in the GoldMine E-mail Center


DATABASE SCHEMA CHANGES IN GOLDMINE PREMIUM EDITION 9.0.1
New columns in existing database tables
CAL (calendar activities)
Column
Type
Description
GLOBALID
Varchar
Global Appointment ID from Outlook
CONTHIST (contact history)
Column
Type
Description
NUMBER1
Float
Revenue amount for completed sale
NUMBER2
Float
Quantity of units for completed sale



WHAT'S NEW IN GOLDMINE PREMIUM EDITION 9.0


Operating System Compatibility
Windows 7 is now supported, both in 32-bit and 64-bit versions.

Windows Server 2008 R2 is now supported.


Dashboards
Dashboards provide a real-time, graphical, and interactive view into key business processes.  GoldMine Premium Edition includes eight standard dashboards and also provides a Dashboard Designer for administrators to create additional dashboards, representing data in GoldMine or in other databases.  Please see the GoldMine documentation for details.


Outlook Integration
Outlook integration includes several major enhancements in this release.

	New GoldMine panes in Outlook show related contact information.  Administrators can configure the display to select the fields and layout to be shown in Outlook.
	E-mails can be linked to contacts, opportunities, projects, and cases from Outlook.  

Automatic linking for messages sent and received in Outlook, with the ability to prompt the user to find or create a contact if there is no matching e-mail address in GoldMine.
	Centralized administration for Outlook synchronization enables administrators to set synchronization settings and schedules for GoldMine users. 
Support for recurring activities when synchronizing with Outlook
Option to automatically link attachments without prompting the user.  In Outlook, go to Setup GoldMine Plus > Options > Use GoldMine attachment handling settings.  This option will apply the Existing Attachment Default Action that is established here in GoldMine:  Tools > Options > E-mail > More Options > Advanced.  
One-Button Synchronization Profiles can be applied without using the GoldMine internal e-mail client.  To update a profile when using Outlook for e-mail, save the profile attachment from the e-mail in Outlook, open GoldMine, go to Tools > Synchronize > Synchronization Settings, browse to the file, and click Update.
Outlook can be used for composing messages when clicking the E-mail hyperlink in GoldMine.  Go to Tools > Options > E-mail and click Use Outlook for linked e-mail addresses.
Improved usability in Outlook when re-linking an e-mail message to a different contact 
A new navigation pane in Outlook displays clickable links to recently viewed items in GoldMine, to make it easier to switch between applications.
An option to include the contact’s address in the subject that appears in Outlook after synchronizing calendar items.  Go to Tools > Configure > Outlook Integration Settings > Sychronization > Set Up… > Next > Advanced and check Add contact’s address to subject.


Administration
GoldMine includes native support for Microsoft SQL Server Express instead of the Firebird database.  Firebird is no longer a supported database in GoldMine Premium Edition.  During the upgrade to GoldMine Premium Edition 9, a default Firebird database will automatically be rehosted to Microsoft SQL Server.  After the upgrade, GoldMine will rehost any other Firebird database if a user attempts to open it.

GoldMine now supports unattended installation for undocked users and environments with multiple GoldMine configurations.  Go to Tools > Configure > System Settings > Script for Unattended Installation and select the type of configuration to install, and fill in the fields shown.  Then click Create to generate .ini and .bat files that are used, along with gmsetup.exe, to install GoldMine without requiring a user to click through the installation wizard.  Please read the GoldMine Install Guide for more information about unattended installation.

New options for password policy are included.  Administrators can set the following policies at Tools > Configure > System Settings > Password Policy:
Minimum password length
Block accounts after three invalid login attempts
New password cannot repeat any previous password, up to a specified number of previous passwords

GoldMine now provides a master list of all field label names and database names, to facilitate data import and export.  Go to Tools > Configure > Record Types and click All Fields in the left panel.  A list of all contact database fields and labels will be shown, for view or export to Excel.


WHAT'S ENHANCED IN GOLDMINE PREMIUM EDITION 9.0


Search
The options shown in the "Search By" list in the Contact Search Center can be reduced to improve usability.  Go to Tools > Options > Lookup > More Options and check the boxes corresponding to fields you want to use for searching in the Contact Search Center.

Last Name is now an option in the Search List drop-down in the Contact List, to simplify searching for a contact by last name.

The Search List selection in the Contact List is now retained between sessions, so your preferred method of searching is kept automatically. 

When the SQL Query Editor is used in the Contact Search Center, GoldMine now shows a clear error message to the user if the SQL syntax is incorrect.


Administration
For improved auditing, archiving, and smartphone access to messages generated within GoldMine, there is a new option to force all e-mail sent to a user to go through the mail server.  To enable or change this setting, go to Tools > Users’ Settings > Properties > Choose how to deliver e-mail messages to this user

GoldMine now automatically repairs corrupted e-mail records, rather than displaying a "Cal record for this e-mail is missing" message as in previous versions.

With the ClearTLogByDelFilter setting customers can control whether to delete TLog records when applying a deletion filter during synchronization.  This setting is placed in the [GoldSync] section of the GoldSync.ini file.
	To delete TLog records (default):  ClearTLogByDelFilter =1

To retain TLog records:  ClearTLogByDelFilter=0


Calendar
GoldMine now provides the option to add or remove users and contacts from an existing activity.  To use this feature, edit an existing activity and select the Contacts tab or Users tab to make changes.

GoldMine now provides the ability to schedule recurring activities with no end date.  When this option is used, GoldMine will add a number specific instance of activities corresponding to the recurring activity, and then continue to add more over time to keep calendars booked appropriately.

The Preview Pane in the Activity List now includes a hyperlink to navigate to the contact record related to the selected activity.

With the EditWhenDblClick setting customers can choose what happens when they double-click on a calendar item.  This setting is placed in the [CalObj] section of the <username>.ini file.
	To open the activity (default):  EditWhenDblClick=1

To open the contact record:  EditWhenDblClick=0


Customer Service
Column and Tab Selection in Case Management is now applied only to the logged-in user, not changed globally.  Other customizations, as shown on the Labels and Options tabs, are now read-only for users without Master Rights.

Case Tasks now have a lookup list available to make task names more consistent and easier to enter.


Marketing Campaigns
Marketing campaigns now include the ability to add a contact group or filter to an existing campaign.  Select a campaign, click Assign Contacts, then select Link All Group/Filter Contacts.


WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.0 HOTFIX 2

ID #
Issue Description
127906
Performance issues when browsing through e-mails in Outlook 
126948
Contact2 data does not print for non-master users when merging with template
125956
Upgraded HTML notes appear as text with exposed HTML tags
125332
Outlook becomes non-responsive for several seconds when moving an e-mail message from one folder to another
125284
Cannot link Outlook e-mails to curtained contact records owned by a user group with long name
124969
While linking an e-mail to a contact record, Outlook is not responsive for 6-10 seconds
124561
Only one instance of Outlook sync can be started when running via Terminal Services
122182
Activities for today are not shown on Sales User Dashboard
110951
E-mail server Communication Timeout cannot be higher than 30 seconds


WHAT'S FIXED IN GOLDMINE PREMIUM EDITION 9.0.0

ID #
Issue Description
120111
Selecting different filters on the Filters tab may cause erroneous filter name to be displayed
117221
When all opportunities are shown in the opportunity manager, the pipeline chart only shows opportunities owned by a single user
115456
GoldMine Plus for Microsoft Word shows error message when several standard users are working in Windows 2008 Terminal Services
114357
Cannot set GoldMine as default e-mail client on Windows 7
114133
GoldMine Address Book not available for selection after installation due to buffer overflow
113759
From: address is incorrect in a redirected e-mail
113683
"Look-up a replacement value in lookup.ini" is grayed out for Update Field action in Automated Process options
113653
When select 5 hours in graphical calendar, the scheduled activity defaults to 5 minutes
113568
Lookup list for Code field is different when creating a Project from when editing a Project
113476
Application error when changing to non-default Status value while closing lost Opportunity
113457
Opening the case management module is slow when you have a lot of cases in the database
112858
Link to opportunity or project is broken when sending an e-mail message
112855
E-mail created from Opportunity/Project Manager Influencer/Contacts tab has empty Regarding field 
112851
When editing multiple extended details in succession GoldMine will edit the last detail and not the current one highlighted
112792
Performance issue when browsing through records after selecting first record from Contact Search Center
112135
Regarding: field in e-mail window shows items sorted by creation date, not alphabetically
111974
'Font increase' and 'Font decrease' buttons work only after the font is manually changed using 'Font' button
111846
Incorrect results in Contact Search Center if no Contact2 column is shown when applying a power search filter with Contact2 fields 
111800
User speller file is not generated correctly
110090
Resolved Date for cases does not synchronize back to server if case was created on remote system and previously synchronized to server
110085
Cannot add a contact with empty Company field to a case
109921
Error when opening e-mail from sender with apostrophe in e-mail address
109341
When performing a two-way sync with Outlook, some calendar items become unlinked from contacts in GoldMine
109030
Upgraded opportunities not displayed when selecting a user group in the Manager dropdown
109027
The drop-down list for Manager in the opportunity detail view does not include user groups
108594
User and Date are not populated in 'Assigned Cases by User' report
108270
Create Unicode Database option is enabled during upgrade but has no effect
108023
Copy current record takes wrong current record information when auto-retrieval in background is active
107943
When a new user logs in for the first time, Case tab names are reset to default settings
107638
the f2 lookup for product in a new opportunity shows incorrectly if the product field has cross-field validation in the forecasted sale dialog
107133
E-mail address for additional contact gets deleted from database when record is opened by user associated with recid ending in a space
107116
Reference column is too narrow in task list on calendar
107021
Preview pane in Opportunity History tab does not display e-mails 
106872
Activities occurring on the same date in Case History are displayed in incorrect order after sorting by date
106611
"Auto name assignment" setting for attachments in GoldMine is not applied when forwarding e-mail in Outlook
106564
Incorrect labels shown in preview pane for completed Case Task
106529
GMAPI call MenuCommand produces “Access Denied” status
106472
Opportunity Forecast field does not refresh when adding sales line items
106426
Number of units and price are not visible in Opportunity detail view after closing Opportunity
106295
Extended detail tabs do not sort in date order correctly
106112
When adding a Competitor to an Opportunity, the Select button adds the first Competitor from the lookup list
105380
Unlinked phone message does not save the Contact name entered
105317
F2 lookup for Product field varies, depending on where the field is accessed
105310
Switching from Fields tab to Summary tab causes incorrect editable fields to appear
105253
There is no vertical scroll bar for Tasks in Opportunities or Projects
105235
Users without master rights cannot see cases associated to curtained contact records owned by a group of which user is member 
105113
HTML e-mail font changes when clicking in the top left of the e-mail body
104975
Cannot link messages to additional contacts in Outlook
104879
EditWhenDblClick setting produces inconsistent results when double-clicking on an activity
104782
Font is set to Times New Roman 3 while composing new e-mail from HTML template
104757
'Remember lookup by' option does not retain 'contact (primary and additional)' selection after closing contact search center
104734
When E-mail Center is opened, keyboard focus is on the folder tree rather than the message list
104688
Changes made to tabs of master users do not remain static
104672
User column in History contains wrong value when overriding required field entry
104655
'Send Outlook Message' defaults always to Plain Text format if a default template exists in GoldMine
104635
Changes made to maximized Case Description field do not save 
104550
E-mail fields [subject, date, linked to, from] occasionally disappearing when opening e-mails linked from Outlook
104192
Only one instance of a recurring GoldMine appointment syncs into Outlook
104191
Time Clock sorts dates numerically, not chronologically
104177
Contact Search Center does not display more than two decimal places for a numeric field
104080
Main Dictionary Language does not have a default value
103837
Only one case is included in service report when run for current contact only
103818
Ctrl + C does not copy highlighted text on Pending or History preview pane
103808
Incorrect results in contact search center with Power Search using filters 
103729
Cannot use tab key to select field displayed off screen in Fields tab
103727
Last Attempt is only updated by an unsuccessful call or message, not any other activity
103702
Revoked menu items are still visible for GoldMine user
103674
revoking ALL rights and almost all menus from a User still allows User to change / create Relationships and set access options
103638
Inconsistent retention of Show field between Activity List sessions
103608
Notes field from extended details are not displayed on reports
103418
GoldMine macro in e-mail subject line pulls data from active contact instead of merged contact if filter/group is selected before template
103192
When replying to an e-mail with spell checking disabled, double-clicking the Send button causes application error
103040
Non-Master users see non-functional menu items for features that are only available to Master users 
102971
Required Fields setting does not alert always
102797
Incorrect sort on Date column for Extended Details 
102790
Merged document has different format for Phone1 and FAX fields 
102751
When replying to plain text emails, HTML formatting is set if using original text in reply
102643
Tempdb is not used when running reports, so users require more rights than needed in previous versions
102609
When replying with original message, the whole original message is not included if it contains "<< >>"
102581
When entering F2 lookup, // is required when creating non-displayed descriptive info but list shows the descriptive info in parentheses.
102566
Clicking header to sort Activated and Previewed filter in Contact Search Center releases filter but doesn't change tab text
102539
Selecting Relate to when creating a New Record will not add an relationship tree to existing record if one does not already exist
102477
E-mail fields [subject, date, linked to] intermittently disappear when scrolling through inbox
102474
Using an e-mail template to reply doesn't allow quoting original message with '>>' symbol
102412
User preference for 'Show numerics aligned to the right' does not stick for non-master users
102410
calendar displays closed amount of a forecasted sale on all completed activities
102373
E-mail message body is lost after closing error message regarding digital certificate
102290
when creating a opportunity after editing one the opportunity always defaults to the first if you edited
102277
Completion of a Literature request is based on the Assigned To field, not on who completes the literature request
102213
Relationship tab does not refresh properly when expanding a section
102032
Import from Outlook does not bring Notes over correctly
102020
When editing a follow-up activity that did not have Send a request selected but this option was selected on original activity, Send a Meeting Request Update is checked
102017
Delete key does not work when trying to remove attachment from outgoing e-mail
102009
Reports Center does not display preview of report if HTML_CAL_NOTES=0 is set
102001
Cannot copy/paste e-mail headers
101909
When scrolling between cases, the notes from the last case are displayed
101906
User name is incorrect on the History tab in a Case when the user name starts with a "K"
101846
Contact record focus changes after filing message with Sync Contact enabled
101713
Activity List displays wrong entries after automatically releasing an active contact filter
101704
If e-mail address is set as required data entry, user is prompted to fill in all required fields when creating a new record with an e-mail address
101687
&nameaddress macro in GoldMine Plus for Word puts a comma after the State 
101686
HTML_CAL_NOTES=0 setting causes pending and completed activity notes to suppress blank lines
101632
When editing a History record you cannot click the New button to create a new opportunity
101613
Add ClearTLogByDelFilter setting to optimize sync performance with deletion filter 
101592
When pasting text, an extra carriage return is added to the e-mail body
101567
Cannot drag and drop files from Windows Explorer to Details/Links tab of Opportunity
101564
When using a rich-text e-mail as a default reply template, the font always defaults to Times New Roman
101482
GoldMine installer does not alert user that Windows 2000 is incompatible
101381
Address macros that include City, State, ZIP have an extra comma
101372
Expanded details labels are incorrect when selecting the Setup or Info tab for the detail
101287
After closing e-mail message tab, focus shifts to the E-mail Center folder tree and not the e-mail message list
101257
The Copy Current Record box adds data to new record even though it has been removed from the dialog box before the record is created
101225
Relationship tab does not refresh automatically after adding a new record to a company.
101213
Some e-mails with embedded images are not linked from Outlook
101212
Days are shown as bold in calendar when containing activities that are removed from display
101208
Contacts under Company are not sorted alphabetically in Contact Search Center
101137
Schedule Follow-up does not carry over time and duration when completing activity via Pending tab or Activity List
100928
Opportunity creation with Wizard should be consistent with creation without Wizard related to Product field. 
100859
Column order from 'Column Selection' dialog is not respected by Contact List grid
100679
Context-dependent lookup setting is not retained if lookup is used in several areas of GoldMine
100587
'Assertion failed' error creating transfer set with serialized sync disabled
100400
List Existing Data option does not apply to all screens
100346
Deleting an activity is slow when using Activity List with Sync Contact option
100236
ADO errors recorded during sync processing
100024
When completing activities, user can bypass Force Valid Input setting by canceling the entry and clicking on a different field
100003
"Daily - DayTimer (detailed)" Fixed page layout creates duplicate entries on the report
99855
Copy current record option does not recognized blank edits
99717
Activating a Relationship tree at root only activates section containing current contact, unless all sections have been expanded
99665
After upgrade some e-mail addresses do not appear next to hyperlink on contact record view
99597
Incorrect times posted for activities falling after time-change
99390
Error sending read receipt message in response to message created in Outlook
99193
Relationship tree couldn't be found if it was created for contact with empty Company field
98821
Inbox tree is collapsed when Deleted folder is selected
97691
Clicking on a date in My Calendar pane may navigate to wrong dates on Weekly view after the 28th of the month
97652
User must reselect e-mail address when sending message to additional contact from the Influencers tab
97031
Field label length is not respected when limited in layout tab of field properties
96949
Merge tagged records does not keep first record tagged if subsequent tagged records are above the first record in the contact search center
96930
Log Away feature does not support passwords over 11 characters
96602
When selecting Users' Security in GoldSync site group, some override options are unavailable
96438
Improper spacing before Country when applying &FullAddress macro
96406
Adding contacts to a Relationships tab with an activated filter does not add all records in the filter
96149
Last field populates with data from current record when creating New Record with Copy current record option and no Contact name entered
96139
When editing from the Contact List view, edits to user-defined fields are not reflected in the Contact List until the user clicks the refresh button
96100
Status number of contacts when sorting a group exceeds the total number of contacts in the group
96032
Deleting system fields from Wide View can interfere with search functions
95952
PHP file from WebImport script generator is programmed incorrectly
95785
Cannot refresh results in Contact Search Center
95747
Ctrl + A to select All in the mail folder no longer works
95692
Users who cannot schedule a forecast sale can still create a sale against an opportunity
95595
Request a return receipt option is not respected when applied in a default template 
95076
Inbound e-mail shows wrong activity type when viewed in Case History tab
95050
Notes duplicated with sync after upgrade
94565
Preference to set alarms by default is not respected when reassigning or escalating cases
94003
User is prompted three times when using Word document with FILLIN prompt
93992
GoldMine not listed as available mail program for mailto protocol on Vista
92886
Detail header records in the CONTSUPP table (rectype = ‘H’) have some blank or null field values after moving record to new database
83612
.docx preview is not displayed in lower right pane of Document Management Center
83595
Output To: >> Word function fails when using a localized version of Word
82882
Crystal Reports ODBC data source limited to SQL Server type, not SQL Native Client
77164
Completing an activity for one user while logged in as a different user displays the name of the original GoldMine user
76904
Process monitor logs appear under the GoldSync site logs in the GoldSync Admin Center
73456
<<cursor>> field is lost after editing existing document template
70932
Ability to select a group or filter of contacts to add to an existing campaign
70443
Cannot create an email rule that applies to case escalation messages
70348
custom details field are being truncated
68895
Notify via E-mail option does not support external e-mail clients such as smartphones
62591
Relationship Tree folders are limited to 68 on root level
61295
Peg Board does not show current data
57569
Date field does not function correctly when using new default Record Type
57387
Cannot drag and drop sections of Relationship Tree
57173
Peg Board column width is not adjustable
57170
Web Site is not copied when using Copy Current Record option
56650
User notifications for scheduled activities are not delivered to external e-mail clients
56624
Output To Printer Option is grayed out in Activity List for Non-Master users.
49788
When editing an existing document in the Document Management Center, carriage returns are double spaced
48519
Nothing returned with &AdditionalContact macro
8775
ITS 17260: Incorrect name displayed on Opportunity related to an Additional Contact


DATABASE SCHEMA CHANGES IN GOLDMINE PREMIUM EDITION 9.0

New database tables

CUSTVIEW (dashboard)
Column
Type
Allow nulls
Description
NAME
Varchar(100)
No
Dashboard’s name
CATEGORY
Varchar(100)
No
Dashboard’s category
USERID
Varchar(8)
No
Who has access (user or group name)
CREATED_BY
Varchar(8)
No
User who created the dashboard
CREATED
Datetime
No
When created
MODIFIED_BY
Varchar(8)
No
User who modified the dashboard
MODIFIED
Datetime
No
When modified
DEVELOPED
Smallint
No
Who developed: 1- FrontRange, 2 – Others
METAINFO
text
Yes
Meta information
recid
Varchar(15)
No
Unique ID

CUSTDATASOURCE (dashboard data source)
Column
Type
Allow nulls
Description
NAME
Varchar(100)
No
Data source name
CATEGORY_ID
Varchar(15)
No
Category id
USERID
Varchar(8)
No
Used for sorting 
CREATED_BY
Varchar(8)
No
Who created
CREATED
Datetime
No
When created
MODIFIED_BY
Varchar(8)
No
Who modified 
MODIFIED
Datetime
No
When modified
DEVELOPED
Smallint
No
Who developed: 1- FrontRange, 2 – Others
RECTYPE
Varchar(1)
No
C – category, D – data source
METAINFO
text
Yes
Meta information
recid
Varchar(15)
No
Unique ID

CUSTRELATIONS (which dashboard uses which data sources)
Column
Type
Allow nulls
Description
VIEW_ID
Varchar(15)
No
Dashboard’s id
DS_ID
Varchar(15)
No
Data source’s id
CONTROL_ID
Varchar(15)
No
Dashboard part’s id
recid
Varchar(15)
No
Unique ID

REPORTTEMP (used for creating reports)
Column
Type
Allow nulls
Description
REC
Varchar(15)
No
Record id
EXPR
Varchar(256)
No
Expression
USERID
Varchar(8)
No
Who is printing the report
CALDEF (recurrence pattern for an activity)
Column
Type
Allow nulls
Description
RECTYPE
Smallint
No
1 = recurrence series pattern
2 = modified exception “pattern”
3 = deleted exception
4 = completed exception
5 = multiple-attendee activity pattern
STARTDATE
Datetime
Yes

STARTTIME
Varchar(5)
Yes

ENDDATE
Datetime
Yes

ENDTIME
Varchar(5)
Yes

DURATION
Smallint
Yes

ENDNOCCUR
Smallint
Yes
The number of occurrences after which the recurrence ends. If specified, the value of ENDDATE is ignored.
Null for exception pattern record.
RECUR_TYPE
Smallint
Yes
1 = hourly
2 = daily
3 = weekly
4 = monthly
5 = yearly

Null for exception pattern record.
INTERVAL
Smallint
Yes
A value which represents how often the activity repeats; e.g. a value of 2 for weekly recurrence means the activity occurs every 2 weeks.
Null for exception pattern record.
SKIPNONWORK
Smallint
Yes
0 = no skip
1 = skip weekend/non-work hours
Null for weekly recurrence.
Null for exception pattern record.
REPEATBY
Smallint
Yes
1 = by specific day
2 = by day of the week
Null for hourly, daily recurrence.
Null for exception pattern record.
ONDAY
Smallint
Yes
For monthly and yearly recurrence, represents: a specific day of the month if Flags = 1; Nth day of the week if Flags = 2.
Null for hourly, daily, weekly recurrence.
Null for exception pattern record.
ONDOW
Smallint
Yes
For weekly recurrence, represents the day(s) of week when the activity occurs. E.g. Sunday and Tuesday = 20 + 22 = 5.
For monthly and yearly recurrence, represents an Nth day of the week if Flags = 2.
Null otherwise.
Null for exception pattern record.
ONMONTH
Smallint
Yes
For yearly recurrence, represents a month of the year (for both Flags = 1 and Flags = 2).
Null for the other types of recurrence.
Null for exception pattern record.
USERS
Text
Yes

List of user items separated by a delimiter; a user item consists of a userid.
RESOURCES
Text
Yes
List of resources separated by a delimiter.
CONTACTS
Text
Yes
List of contact items separated by a delimiter; a contact item consists of an ACCOUNTNO and an optional CONTSUPP.RECID, separated by another delimiter, if the contact is an additional contact.
EXCEPTIONS
Text
Yes
List of exception items separated by a delimiter; an exception item consists of the original datetime of the instance, separated by another delimiter from the type:
1 = modified
2 = deleted
3 = completed
Null for exception pattern record.
COMPEXC
Text
Yes
Data on partially-completed activity occurences
PRIMARYUSER
Varchar(8)
Yes
User assigned to the activity; has full security rights over the activity.
IS_INFINITE
Smallint
Yes
0 = recurrence has end date, or no recurrence;
1 = recurrence is infinite
Null for exception pattern record.
LAST_ROLL_OCCUR
Datetime
Yes
The last instance of an infinite recurrence that was generated during rolling. The next rolling should base its calculation of instances on this value. Null for finite recurrence.
Null for exception pattern record.
ROLL_DATE
Datetime
Yes
For infinite recurrence, date when rolling of recurrence should occur.
Null for exception pattern record.
CREATED_BY
Varchar(8)
No
User who created the activity
CREATED_ON
Datetime
No
Activity creation date
CREATED_AT
Varchar(5)
No
Activity creation time
MODIFIED_BY
Varchar(8)
No
User who modified the activity
MODIFIED_ON
Datetime
No
Activity modification date
MODIFIED_AT
Varchar(5)
No
Activity modification time
ORIG_DATA
Text
Yes
Some original information (color, rectype, ref, private, alarm flag, linked to)
ORIG_NOTES
Text
Yes
Original notes
ORIG_DATE
Datetime
Yes
Original date
ORIG_TIME
Varchar(5)
No
Original time
LINKRECID
Varchar(15)
No
Mail id
ATTENDEES_EX
Text
Yes
List of attendees separated by a delimiter
CALRECTYPE
Varchar(1)
Yes
Type of calendar activity
ORGANIZER_EX
Varchar(100)
Yes
Real organizer’s name if it is not a user
GLOBALID
Varchar(200)
Yes
Global Appointment ID from Outlook
BLOCKEDBY
Varchar(8)
Yes
For internal use in synchronization process
BLOCKEDON
Datetime
Yes
For internal use in synchronization process
BLOCKEDAT
Varchar(5)
Yes
For internal use in synchronization process
recid
Varchar(15)
No
Record’s id

New columns in existing tables

CAL (calendar activities)
Column
Type
Allow nulls
Description
CALDEF_ID
Varchar(15)
No

ORIG_DATE
DATETIME
Yes

ORIG_TIME
Varchar(5)
No

IS_EXCEPTION
Smallint
Yes

CALDEFEX_ID
Varchar(15)
No

FLAGS
Int
Yes

ATTENDEES_EX
Varchar(100)
Yes


CONTHIST (contact history)
Column
Type
Allow nulls
Description
COMPLETEDID
Varchar(15)
No
Used for synchronizing completed activities

USERS 
Column
Type
Allow nulls
Description
EMC_ACC_EMAILS
Text
Yes
List of all user’s e-mails
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