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Introduction

GoldMine Premium Edition provides a powerful, comprehensive, integrated, automated solution to
managing customer relationships. It contains tools to develop contacts, conduct activities, and track
progress. With GoldMine’s synchronization features, users working remotely can access some data from
the main company database. Goldmine can also synchronize with Outlook and Google Apps Calendars.

GoldMine Connect allows you to use selected features of GoldMine Premium Edition via a web browser.

This guide describes the basic components and steps for installing GoldMine Premium Edition and provides
information about integrating GoldMine with your other technology tools.

About this Guide
The GoldMine Premium Edition Installation Guide describes the basic components and steps for installing
GoldMine Premium Edition on your Server, Networked Workstations, and Undocked Workstation, and
helps you integrate GoldMine smoothly with your other technology tools.

Audience and Expertise
This information is pertinent for users and system administrators performing installations. It describes the
system requirements, and contains step-by-step installation instructions and tips for server setup,
workstation setup, and undocked user installations.

This material assumes that the user understands how to use theMicrosoft Windows operating system for
installations.
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System Requirements

This chapter provides the GoldMine system requirement information you need before you begin a Server,
Networked Workstation, or Undocked Workstation installation.

NOTE: Before installing GoldMine, review the most current version of the compatibility matrix
document available for download from: support.frontrange.com.

Permissions

GoldMine
■ Only users with local Administrator rights, or users who belong to the Administrator group, can install

GoldMine.
■ The MS SQL Administrative Username must have permissions to create a new database (for new installations

only).

GoldMine Plus!
■ Youmust have Windows administrator permissions when you install GoldMine Plus for Microsoft Office, in

order for GoldMine Plus to be available globally for all users.
■ GoldMine Plus! must be installed under the user profile of the user that will have the integration.

Environments
Pay particular attention to the system requirements that apply to your environment and license type.

GoldMine can be installed and run in various environments. For example, you can install GoldMine on a
dedicated Server, or select a regular computer running a server operating system to host a server
installation (see Server Requirements). Environment is influenced by database size and capabilities,
performance considerations, number of shared/undocked users, etc.

Host Requirements
Requirements are listed for the following:

■ Server Requirements
■ Workstation System Requirements
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■ Undocked Workstation Requirements

Software Requirements
■ Microsoft Internet Explorer 7.0 or newer
■ Microsoft Windows Installer 4.5 or later (For SQL 2008 - might require server restart).

Server Requirements

Operating Systems
HEAT Software supports these operating systems for the GoldMine Application Server:

■ Microsoft WIndows 7
■ Microsoft Windows 8 and 8.1
■ Microsoft Windows Server 2012
■ Microsoft Windows Server 2012 R2
■ Microsoft Windows Server 2008 R2
■ Microsoft Windows Server 2008

If you are using Microsoft Small Business Server 2008 or 2011 or Windows Server 2012 0r 2102 R2 Essentials, it
must be installed and working prior to installing GoldMine. Ensure that SQL Server and SBS service packs are
current and applied.

Network Protocols
■ TCP/IP (recommended)

Database Requirements
NOTE: Ensure that the SQL edition and version are compatible with the Microsoft Operating
System used at your installation.

■ Server Database (must be installed and configured)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2008 SP2
○ Microsoft SQL Server 2008 R2
○ Microsoft SQL Server 2008 R2 SP1
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014

■ Reporting Services (must be installed and configured to use the Scheduled Reports feature)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014
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■ Full Text Search (must be installed and configured to use Full Text Search feature)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014

■ Client Tools (must be installed prior to initiating the GoldMine installation process if you intend to perform a
Server installation to share your database.)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014

IMPORTANT: A minimum ofMicrosoft SQL Express 2008/2012 with Advanced Services is required for the
GoldMine database. SQL Express editions have a maximum database size:

m SQL Express 2008/2012 = 10 GB

Additional Server System Requirements
■ Microsoft Data Access Components (MDAC) 2.6 or higher. MDAC is installed automatically with SQL Server.
■ SCSI or Ultra DMA Enhanced IDE hard drives: RAID Array or mirrored (recommended).
■ 1GB/100 MBps network connection (recommended).

Server Memory Requirements
NOTE: The following table listed recommended RAM allocations. Your actual RAM requirement
can vary depending on other Performance Considerations. Insufficient RAMmight cause you
machine to process data more slowly.

Database Size Minimum RAM Allocation

50 MB 128 MB

100 MB 256 MB

500 MB < 2 GB 512 MB

2–5 GB 1 GB

5–12 GB 2 GB

12+ GB 3 GB

NOTE: Youmight also need to increase your RAM allocation when using Universal Search and Full
Text Search in GoldMine.
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Performance Considerations
The amount of RAM you have in your Server and the CPU speed requirements vary depending upon your
database size and these factors:

NOTE: These factors are in addition to the database size and RAM recommendation listed in the
table for Server Memory Requirements. For example, if you have 2 GB of mailbox records, you
would need to increase the RAM tomatch the recommendations accordingly.

■ Number of items in the database:

○ Contact Records (1 KB each)
○ Detail Records (2 KB each)
○ History Records (1 KB each)
○ User-defined fields

■ Number of simultaneous users on the network
■ Database size
■ Mailbox records (often the largest table andmost used)

Workstation System Requirements
Microsoft Data Access Components (MDAC) 2.6 or higher must be installed on any shared or undocked
workstation to enable database functionality. MDAC is installed automatically with SQL Server.

NOTE: HEAT Software neither supports nor recommends using Windows emulators onMacintosh,
Linux, or other operating systems.

Operating Systems
This release of GoldMine Premium Edition supports the following operating systems for the GoldMine
Network Clients. Refer to the Compatibility Matrix for specific information.

■ Microsoft Windows 8 and 8.1
■ Microsoft Windows 7

Hardware Requirements

Operating System CPU (Intel or AMD) RAM

Microsoft Windows 8 & 8.1 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Microsoft Windows 7 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)
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Undocked Workstation Requirements
Microsoft Data Access Components (MDAC) 2.6 or higher must be installed on any shared or undocked
workstation to enable database functionality. MDAC is installed automatically with SQL Server.

The following recommendations are made for computers operating when disconnected from a Server.

Operating Systems
HEAT Software supports these operating systems for the GoldMine Undocked Clients:

■ Microsoft Windows 8 (32 bit & 64 bit)
■ Microsoft Windows 7 (32 bit & 64 bit)

NOTE: HEAT Software neither supports nor recommends using Windows emulators onMacintosh,
Linux, or other operating systems.

Hardware Requirements

Operating System CPU (Intel or AMD) RAM

Microsoft Windows 8 and 8.1 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Microsoft Windows 7 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Performance Considerations
The amount of RAM you have in your Workstation and the CPU speed requirements vary depending upon
your database size and these factors:

■ Number of items in the database:

○ Contact Records (1 KB each)
○ Detail Records (2 KB each)
○ History Records (1 KB each)
○ User-defined fields

■ Number of simultaneous users on the network
■ Database size
■ Mailbox records (often the largest table andmost used)

Additional Requirements
■ Microsoft .NET Framework 1.1must be installed and configured to use the Scheduled Reports feature.
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■ Microsoft .NET Framework 2.0 is required for: GoldMine Plus (add-on for Microsoft Office).
■ Microsoft .NET Framework 4.5 is required for installation of GoldMine Premium Edition. If it is not found, it will

be installed automatically.

■ Microsoft Visual Studio 2008 .NET (for use withMS SQL 2008) must be installed and configured to create reports
for the Scheduled Reports feature. End users do not require this application.

GoldSync Requirements
GoldSync automates the synchronization of data between a host GoldMine system and multiple remote
GoldMine systems.

GoldSync supports multi-user/multi-site environments and includes support for many simultaneous
connections. As the amount of data and number of users increase, GoldSync scales as needed for the
workload demand.

TIP: For details on GoldSync implementation and functionality, see “About GoldSync" in the Online
Help.

GoldSync System Requirements

Item Recommended

o Operating System

Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2008

o Disk Subsystem RAID Array or mirrored (for larger databases or heavy synchronization load)

o RAM Allocation 1 GB (for < 2 GB database with 10 concurrent sync sessions)

o Network Connection
100 Base-TX
TCP/IP



Installing GoldMine

GoldMine provides various types of installations, whether from install file or CD, a new installation or
upgrade, on a server or workstation, in network or remote location. Review the planning items and
considerations, determine the type of installation you are running, and use the associated checklist to
ensure a successful installation.

Planning Your Installation
When planning a GoldMine installation consider:

Who will be the designated GoldMine administrator? The GoldMine administrator must have access to
network and office resources and be able to address the business-related implementation issues regarding
configuration and customization.

Do you have the proper license and registration information for the version of GoldMine you are
installing? For detailed information on licensing, see Licensing and Registration

TIP: GoldMine Solutions Partners are GoldMine Certified in installation and setup. To locate a
partner in your area, go towww.goldmine.com and use the Partner Locator.

Are you going to import data? Verify that you can import the source data into GoldMine.

Does the system administrator have full administrative rights? To install GoldMine on a network, the
GoldMine administrator must have full administrative rights on the network.

Are your service packs compatible and current? Check the version and service pack number for your
Microsoft Windows operating system. Verify no issues exist with your current service pack. Go to
https://support.frontrange.com, log in, and navigate to Technical Support > Support Documentation >
Technical Manuals > GoldMine. Select GoldMine Premium Edition.

Have you reviewed the network structure?
○ Are there multiple domains? Do users have the rights on the GoldMine domain to access GoldMine?
○ Is the server outside the regular network? There may be connectivity issues the network administrator

needs to address.

What type of database are you using? GoldMine supports both Microsoft SQL Server or SQL Server
Express.

Will you be integrating GoldMine with Microsoft Office?Microsoft Office 2007/2010 is required when
integrating with GoldMine, and must be installed/configured before installing the GoldMine Plus!
component.

NOTE: GoldMine does not support the Microsoft Office 64 bit versions.
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Installation of GoldMine on Windows 7, or Windows 8 or 8.1
■ You can install and run GoldMine onWindows 7, or Windows 8 or 8.1, but you cannot share your installation with

other NetworkedWorkstations over a network (i.e. they are not supported as application server
environments).

■ The installer will offer customized path settings for GoldMine's program files. The installer, by default, creates
the destination folders with correct permissions set for proper use. If the destination folders you will install to
already exist, or if you create them yourself, youmust ensure that the selected folders have the correct access
permissions.

NOTE: Installing to the default path is highly recommended.

Installation of Universal Search
The Universal Search feature provides a single view to quickly find out what information is in your system and
how to navigate to it. Universal Search can be installed by selecting Yes at the end of the Licensing Wizard (see
Licensing Following Installation), or by using one of the following procedures:

■ To Install Universal Search fromWithin GoldMine
■ To Install Universal Search from a Command Prompt

IMPORTANT: MS SQL Full Text Searchmust be correctly installed and configured prior installing
Universal Search.

For information about using Universal Search, refer to the “Universal Search” topic in the GoldMine Premium
Edition User Guide pdf or in the Online Help.

To Install Universal Search from Within GoldMine
1. Logon to GoldMine as user withMaster rights.
2. Open the Toolsmenu and select Configure > System Settings.
3. Click the Advanced tab.
4. Click the Install button.
5. Click the Yes button.

To Install Universal Search from a Command Prompt
1. Logon to GoldMine as an administrative user when prompted for logon data
2. Open the WindowsStartmenu and select Run.
3. In the Open textbox, type gmw /us:install and then clickOK.
4. Login to GoldMine as an administrative user when prompted for logon data.
5. Install Universal Search by selecting Yes in the Do you want to install Universal Search?message box.
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Searching E-mails in Windows 7, or Windows 8 or 8.1
There is an issue when searching information in emails that occurs only when GoldMine is installed on
Windows 7, or Windows 8/8.1.

After installing Universal Search you might see the following messages:

■ Message in the Application Event log:
Errors were encountered during full-text index population for table or indexed view '[gm81_35].[dbo].
[MAILBOX]', database 'gm81_35' (table or indexed view ID '309576141', database ID '20'). See full-text crawl
logs for details."

■ Message in the full text log:
"2009-09-12 19:12:30.13 spid18s Error '0x8007007e' occurred during full-text index population for table or
indexed view '[gm81_35].[dbo].[MAILBOX]' (table or indexed view ID '309576141', database ID '20'), full-text
key value 0x354C4F4A583248263B3F563D20573C. Attempt will be made to re-index it.
2009-09-12 19:12:30.13 spid18s The component 'MSFTE.DLL' reported error while indexing. Component path
'C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\MSFTE.DLL'

To fix this condition, perform the following procedure.

WARNING: It is recommended that you create a backup of your Windows Registry before making
any changes.

1. Find the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{5645C8C2-E277-11CF-8FDA-00AA00A14F93}

2. Change the default value from
(%systemroot%\system32\mimefilt.dll) to (c:\WINDOWS\system32\mimefilt.dll)
where %systemroot% is the path where Windows is installed.

3. Restart the computer (or at minimum restart the Microsoft SQL Server).
4. Restart the Microsoft Fulltext service
5. Re-install the Universal Search (see Installation of Universal Search).

After installing Universal Search youmight see the following message:
“You can see this message only in the Application Event Log”

System Files Changes
Located in the GoldMine folder, these files store user and licensing information. System files typically have a
.BIN, .XML, or .INI file extension.

■ DataDict.xml includes database and field definitions for creation of required databases andmaintenance
operations.

■ flags.bin controls the number of users logged on to GoldMine.
■ LicenseGM94.bin stores License Manager information and validates incoming sync connections.
■ Users is a table the collects the user's information such as user login and permission information.
■ USER_info.bin stores SQL login information.
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■ GM.ini controls how GoldMine launches.
■ dbalias.ini stores the database username and password.
■ gmbase.bin is used tomaintain system integrity.
■ gmexp.bin stores revoked licenses.
■ SyncLock.bin is used tomaintain system integrity.
■ USER.ini stores how GoldMine launches for the user.

Changes to System Files for Microsoft Windows 8,
Windows 7, Server 2012, and Server 2008

When installing GoldMine onto: Microsoft Windows 7, Windows 8, Windows 8.1, Windows Server 2008,
Windows Server 2008 R2, Windows Server 2012, or Windows Server 2012 R2 system, a split-path installation is
used due to security changes in these versions ofWindow’s architecture. The split-path installation will place
executables and program libraries into \Program Files\GoldMine, while database files, .INI files, reports,

and templates are placed in \ProgramData\GoldMine.

NOTE: It is highly recommended that you install to the default paths.

Installation Checklists
If you are: Then run:

NetworkedWorkstation:An individual in an organization with a multi-user
environment whomust connect to a shared copy of the GoldMine database. Install
GoldMine on the client workstation so the end user can connect to the server copy
of the GoldMine database from his or her individual computer.

Full Setup, connected
to an existing database

UndockedWorkstation:An individual who often works remotely on a computer with
an Undocked sublicense, who synchronizes with a Server to update information.
Install a full copy of GoldMine with a database on a computer working disconnected
from a network.

Full Setup
(with U-License)

GoldSync Server: This can be also the Server and does not need to be an extra
machine.

Full Setup, connected
to an existing database

Server:A company that must support multiple GoldMine users using a shared
system. Users can then connect to the server copy from their local Networked
Workstation using shortcuts installed by running a Workstation installation.

Full Setup
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Server Installation Checklist
Back up your database and folders: (Upgrading customers only) If you are upgrading, back up your GoldMine
database. We also recommend backing up your GoldMine folder and any other folders containing files linked
to GoldMine before beginning any installation. This prevents the loss of valuable contact information.

Confirm all GoldMine users are logged out of the system: (Upgrading customers only).

Uninstall linked and integrated programs: (Upgrading customers only) Uninstall GoldMine Plus for Microsoft
Office.

Exit all running system programs and stop services: Includes third-party utilities that integrate with GoldMine,
other GoldMine add-on products (such as GoldSync), the Microsoft Office Shortcut bar. Stop all services that
integrate with GoldMine if applicable.

Install ancillary programs: Install necessary programs on the computer serving as the Server or on another
computer on your network (see Additional Requirements). On an Undocked machine, MS SQLmust be
installed prior the GoldMine installation.

Install GoldMine: Install on the computer serving as your Server. Select the Server Setup installation and follow
the directions in this manual.

License the server copy of GoldMine: Licensing registers the Server copy of GoldMine with the appropriate
license (see Licensing and Registration).

Verify you can launch GoldMine: Ensure the server installation is functioning properly before installing any
Networked Workstation.

Share the GoldMine folder: In order for the Networked Workstation to connect to the shared copy of
GoldMine, you must first share the folder in which GoldMine is installed (see Sharing the GoldMine Folder on
the Server).

Networked Workstation Installation Checklist
Uninstall linked and integrated programs: (Upgrading customers only) Uninstall GoldMine Plus for Microsoft
Office.

Exit all running system programs and stop services: Includes third-party utilities that integrate with GoldMine,
other GoldMine add-on products (such as GoldSync), the Microsoft Office Shortcut bar. Stop all services that
integrate with GoldMine if applicable.

Create a mapped drive to the shared GoldMine folder: See Sharing the GoldMine Folder on the Server.

Install GoldMine on the Client Workstation: See Installation on a Networked Workstation.

Verify you can launch GoldMine: Ensure the workstation installation is functioning properly.
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Undocked Computer Installation Checklist
Create an Undocked license: (undocked license users only) See Licensing and Registration.

Uninstall linked and integrated programs: (Upgrading customers only) Uninstall GoldMine Plus for Microsoft
Office.

Exit all running system programs and stop services: Includes third-party utilities that integrate with GoldMine,
other GoldMine add-on products (such as GoldSync), the Microsoft Office Shortcut bar. Stop all services that
integrate with GoldMine if applicable.

Disconnect the laptop from the network: Disconnect to ensure GoldMine configures the laptop to connect only
with the database on the local computer and not with the network.

Install GoldMine to the undocked computer: See Installation on an Undocked Computer.

License GoldMine: Use the appropriate U-license information. See Licensing and Registration.

Verify you can launch GoldMine: Ensure the undocked installation is functioning properly.

Installation on a Server
A full setup installs GoldMine to a common location, usually a shared network drive. Workstation-based users
can connect to the server copy from their local computers after Installation on a Networked Workstation.

IMPORTANT: If you are installing a new version of GoldMine after uninstalling a previous version, you
might have entries left in the Windows Registry which will cause GoldMine to assume you are upgrading.
These entries must be removed to allow you to install GoldMine. Consult with your System Administrator
before you attempt to remove any entries from your Windows Registry.

NOTE: Windows Server 2008,Windows Server 2012,Windows 7, andWindows 8 have a split path
installation. The gm.ini file installs into the \ProgramData\GoldMine, which needs to be shared

because this folder contains gm.ini to which realini setting from workstation gm.ini should point.
(realini=path to shared gm.ini)

To Install GoldMine on a Server
The following steps are for a New Installation. If upgrading, use the steps in Upgrading GoldMine.

NOTE: 110MB of disk space is required for installation (plus 45MB more if adding GoldMine Plus!).

1. Log directly into the server as a local administrator.

2. The installation CD is set up to autorun when inserted into your CD-ROM drive or run the gmsetup.exe
downloaded to your server installation of GoldMine during the Net-Update process.
TheWelcome to the GoldMine InstallationWizard dialog box appears.
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3. ClickNext. The Readme dialog box appears.
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NOTE: The README file contains the most recent information about this version of GoldMine. A
copy of the README.htm (as well as the ReleaseNotes.rtf) can be found in the \Goldmine folder
after the installation has completed.

4. Close this dialog box after reviewing the most recent information about this version of GoldMine to proceed
with the installation.

5. The License Agreement dialog box appears.
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6. Review the licensing information carefully; if you agree to the terms, select I accept the terms in the license
agreement.

NOTE: If you do not agree to the terms of the license agreement, select I do not accept the terms
in the license agreement. Click Cancel to terminate the installation.

7. Accepting the terms of the agreement activates the subsequent check boxes. Youmust select both check boxes
to continue with the installation.

NOTE: Select I am an authorized agent and/or representative of the customer/end-user and I
have read the terms and conditions stated above to continue.

8. ClickNext. The New or Existing Database dialog box appears.
9. Choose the Install GoldMine to connect to a new database option.



Page 19 of 72

10. ClickNext. The Custom Setup dialog box appears.
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The GoldMine Premium Edition and GoldMine Plus! options are selected for installation by default.

NOTE: If you select the Microsoft Excel option and plan on having others use it, besides the
current installing user, youmust make changesmanually to the registry key. SeeModifying the
Registration Key.

There are three options under the GoldMine Plus! option:

○ For Microsoft Word
○ For Microsoft Excel
○ For Microsoft Outlook
If you do not want to install the GoldMine Plus! components, click the GoldMine Plus! icon, select This feature is
not available from the drop-downmenu, and then clickNext. You can also choose to exclude individual
GoldMine Plus! components during the installation.
These components can be install at a later date using the Add or Remove Programs control panel inWindows,
and then selecting Change for the GoldMine entry on the list.

11. To install the selected GoldMine features, clickNext.

NOTE: Microsoft Office must be installed prior to installing GoldMine Plus! components.

12. The Demo Data Options dialog box appears.

13. Select the correct local version of English for your installation.
14. To add the demonstration data to the database, check the Install Demo Data with GoldMine box.

NOTE: When upgrading, this dialog box does not appear
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15. ClickNext. TheMS SQL Administrator Login dialog box appears.

○ MS SQL Server Name:Type or select the name of the computer on your network where SQL Server is
installed. When using named instances (such as default onMS SQL express Editions installations) type the
name of the MS SQL Server; example: MACHINENAME\SQLEXPRESS.

○ MS SQL Database Name:GoldMine creates and installs the demo data in a SQL database called GoldMine. If
you want your database to have a different name, type it in the text box.

○ MS SQL Administrative Username:The default login is sa. If your SQL Server user name is different, your SQL
administrator must provide the information.

○ MS SQL Administrative Password:Enter the SQL Server administrator password.
○ MS SQL Database Owner:The default name of the SQL Server database owner is dbo. There is no need to

change this value.
○ Create Unicode Database: Check this option to create a Unicode Database. Checking this option will greatly

increase the size of your database.

NOTE: If you clickNext without typing a user name and password, the Insufficient Input dialog box
appears. Click Back. If you enter incorrect information and clickNext, theMS SQL Login Failed
dialog box appears. Review the troubleshooting tips, then click Back.

16. ClickNext to continue.

IMPORTANT: Microsoft SQL 2008/2012/2014 Express with Advanced Services is the minimum
requirement for the GoldMine database. SQL Express editions have a maximum database size of 10 GB.

17. The Ready to Install the Program dialog box appears.
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If you are planning on installing GoldMine on other computers, you can check the Create a configuration file for
unattended installation box to create a configuration file with these settings.

If you choose not to use this option, you canmanually create the unattended installation script (see To Create
an Unattended Installation Script).

18. If you selected any of the GoldMine Plus! options, a Question box appears.

19. Click Yes to install the Microsoft Office add-ins, or clickNo to skip installation of these add-ins and only install
GoldMine.

20. The Installing GoldMine dialog box appears.
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21. When finished, the Installation Completed dialog box appears.
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22. Click Finish.

TheWelcome to GoldMine dialog box appears to begin the licensing process. See Licensing and Registration.

Unattended Installation
Another installation option is the Unattended Installation (also known as Silent Install). This option allows
installation without user interaction. Installing GoldMine using the unattended installation mode recreates
the same steps as a workstation install, using user responses stored in a configuration file.

For example, you perform a full GoldMine installation on a clean computer (a computer with no previously
installed versions of GoldMine) using the connect to existing database option. Then you run the GoldMine
installer in unattended mode on the other computers. GoldMine will be installed into the same directory with
connect to existing database option.

TIP: A GoldMine administrator can create unattended installation scripts for various installation
scenarios.

The Unattended Installer uses a special configuration file named gm_si.ini. For detailed instructions on how
to create this file, see To Create Configuration File for Unattended Installation.

NOTE: The generated gm_si.ini is meant to be deployed to a machine with a similar condition. If

you create a gm_si.ini file from a machine that has been upgraded, the same gm_si.ini can
not be deployed as a new installation in another machine.

To Create Configuration File for Unattended Installation
1. Run GoldMine installer as usual.

For more information on installing, see Installation on a Server.
2. Proceed to Install Welcome dialog.
3. Select the Create a configuration file for unattended installation checkbox.
4. In a default install the file will be created in the:

C:\Program Files\GoldMine\Setup\GoldMine\gm_si.ini

5. Click Install.

The configuration file and bat file (gmsetup_si.bat) will be created.

TIP: You can also create an unattended installation script after installation. For more information,
see Creating an Unattended Installation Script.

NOTE: If the installer in unattendedmode cannot repeat exactly the user mode steps, then the
installer will switch to an interactive mode and the user canmanually continue with the
installation.

To Manually Run the Unattended Installation
Manually run the unattended install using gmsetup_si.bat file.
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NOTE: GM installer files gmsetup.exe, gm_si.ini, and gmsetup_si.bat should be placed into
the same directory.

In some cases the unattended installer cannot repeat the exact steps as a normal install. For example, the
unattended installer cannot perform a full installation (without previously installed GoldMine) on the
computer with GoldMine already installed with the same version because the installer is running in
maintenance mode.

Automatic Upgrade
Use the following procedure to upgrade networked workstations.

To Upgrade Unattended Installation
1. Create the configuration file.

For instructions, see To Create Configuration File for Unattended Installation.
2. Select GoldMine > Tools > Configure > System Settings > Auto-Upgrade.
3. Set the paths and filenames of the GoldMine installer and configuration file created in step 1.

NOTE: This must be a UNC path to a sharable directory.

After completing this procedure, any local installs of GoldMine will automatically prompt users to upgrade
GoldMine whenever the local GoldMine version is less then the server GoldMine version.

Installation on a Networked Workstation
A Networked Workstation setup installs GoldMine on the workstation and enables a workstation user to
connect to the Server copy of the GoldMine database from their individual computer.

Share the GoldMine data folder on the server, then map the same drive on each workstation to the shared
GoldMine folder on the server using a UNC path to a sharable directory (not recommended if using
softPhone).

Sharing the GoldMine Folder on the Server
To run the shared folder installation, after installing the Server setup, share the GoldMine data directory
(default: C:\ProgramData\GoldMine\)so the Networked Workstation functions properly. All GoldMine users
must have rights to read, write, modify, and delete files for GoldMine to function on the Networked
Workstation.

NOTE: Sharing can expose other applications. Do Not install GoldMine as a root folder of the drive,
rather, install to C:\Program Files\GoldMine on the Server. We highly recommend installing
GoldMine to the default paths.

Your procedure might vary depending on the operating system where the Server database is located. Refer
the documentation that came with your operating system for detailed instructions.
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To Share the GoldMine Folder on the Server
To share the GoldMine folder on Server 2008 or Server 2012 you must perform two steps: share the folder and
configure the permissions. Follow the procedures listed below to share the GoldMine folder.

Share the GoldMine Folder
1. Open the Windows Startmenu and select Programs > Administrative Tools > Computer Management.
2. In the console tree, expand System Tools > Shared Folders and right-click on Shares.
3. On the Actionmenu and select New Share.
4. Follow the steps in the Create a Shared Folder Wizard, and then click Finish.

NOTE: If you are planning to use a workstation where the Connect to Existing Database Install will
be used, share the \ProgramData\GoldMine data folder.

Configure The Share Permissions
1. Log on to the computer as Administrator or as a member of the Administrators group.
2. Open the Windows Startmenu and select Programs > Administrative Tools > Computer Management.
3. In the console tree, expand System Tools > Shared Folders and click on Shares.
4. In the details pane, right click the shared folder and then click Properties.
5. On the Share Permissions tab, select the Group or User Name.
6. To set individual permissions for the Group or User Name, select either Allow or Deny.

NOTE: Read permission is typically established for the shared: \Program Files\Goldmine folder. Full
permission is typically established for the shared: \ProgramData\Goldmine folder.

Configure the GoldMine Server to Emulate a Network Workstation

When the server is going to be used as a GoldMine workstation, the following shared folder should be
mapped: ProgramData\Goldmine folder

1. Start Windows Explorer and select Tools > Map Network Drive.
2. From the Drive list box, select the designated drive letter for mapping to the GoldMine folder on the server.
3. From the Folder list box, browse to the shared GoldMine folder
4. Select the Reconnect at Logon check box.
5. ClickOK.
6. Click Finish.

Mapping a Drive on the Networked Workstations
All networked workstations accessing the shared GoldMine folder must be mapped to the same network
drive letter (for example, G:\) to facilitate GoldMine administration and operations related to linked
documents and synchronization.

When the Server is Windows 2008 or Windows 2012

The SysDir entry in \ProgramData\GoldMine\gm.inimust be changed so that it points to the mapped folder
containing the LicenseGM.bin file.
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For example, if GoldMine was installed to C: and \ProgramData\GoldMine wasmapped to G:, the SysDir entry
in C:\ ProgramData\GoldMine\gm.ini would be changed to: SysDir=g:\

The RealIni entry in Program Files\GoldMine\gm.ini must be changed so that it points to the gm.ini file in the
mapped ProgramData\GoldMine folder.

For example, if GoldMine was installed to C: and \ProgramData\GoldMine wasmapped to G:, the RealIni entry
in C:\ Program Files\GoldMine\gm.ini would be changed to: RealIni=g:\gm.ini

On each workstation where the Connect to Existing Database Install option will be used, the following shared
folder should be mapped:

\ProgramData\Goldmine folder

To Map a Drive in Windows 7 or Windows 8 or 8.1
1. Open the Windows Start menu and select All Programs > Accessories
2. Right click on Command Prompt shortcut and choose Run as Administrator.
3. Type “net use <drive:> <UNC path to the shared drive> /p:y”

For example: net use g: \\server name\goldmine /p:y

4. Click the Windows Start button, then select Computer and select Map network drive
5. From the Drive list box, select the designated drive letter for mapping to the GoldMine folder on the server.
6. From the Folder list box, browse to the shared GoldMine folder
7. Select the Reconnect at Logon check box.
8. ClickOK and then click Finish.
9. Repeat this procedure on each client workstation computer.

After the GoldMine installation is complete, restart GoldMine. This will facilitate the use of GoldMine with the
GoldMine Plus add-ins.

Installing on a Networked Workstation
TheWorkstation step installs GoldMine on the workstation and enables the workstation user to connect to a
shared copy of the GoldMine database.

1. From the workstation computer, locate the gmsetup.exe file. Double-click to run the executable. The
Welcome to the GoldMine InstallationWizard dialog box appears.

2. ClickNext. The Readme dialog box after reviewing the most recent information about this version of GoldMine
to proceed with the installation.

3. ClickNext. The License Agreement dialog box appears.
4. Review the licensing information carefully; if you agree to the terms, select I accept the terms in the license

agreement.

NOTE: If you do not agree to the terms of the license agreement, select I do not accept the terms
in the license agreement. Click Cancel to terminate the installation.
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5. Accepting the terms of the agreement activates the subsequent check boxes. Youmust select both check boxes
to continue with the installation.

NOTE: Select I am an authorized agent and/or representative of the customer/end-user and I
have read the terms and conditions stated above to continue.

6. ClickNext. The New or Existing Database dialog box appears.

7. Choose the Install GoldMine to connect to an existing database option, and then click the Browse button to
navigate to the to GoldMine shared path on the application server.

8. ClickNext. The Custom Setup dialog box appears.
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The default installation location is C:\Program Files\GoldMine.

NOTE: If you select the Microsoft Excel option and plan on having others use it, besides the
current installing user, youmust make changesmanually to the registry key. SeeModifying the
Registration Key.

IMPORTANT: Choosing a location outside of the \Program Files directory when installing onWindows

7 can cause a loss of certain functionality, such asmacro recording. This is due to security requirements
withinWindows 7, which connects certain privileged functions with the locations from which their
associated executables are launched.

9. ClickOK. The Ready to Install dialog box appears.
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NOTE: The Create configuration file for unattended installation option allows you to create the
gm_si.ini file. This file can be used to establish settings for future Workstation installation based
on the settings of this Workstation.

A GoldMine administrator can also create unattended installation scripts for various installation scenarios (see
To Create an Unattended Installation Script).

10. Click Install. The network shortcuts are installed on your workstation computer.
11. If you selected any of the GoldMine Plus! options, a Question box appears.

12. Click Yes to install the Microsoft Office add-ins, or clickNo to skip installation of these add-ins and only install
GoldMine.

13. When finished, the Installation Completed dialog box appears.
14. Repeat this process for each workstation accessing GoldMine.



Page 31 of 72

Installation on an Undocked Computer
An Undocked setup is the same as a full setup, with the only difference being the license number. For detailed
installation instruction, see Installation on a Server.

If the undocked computer you are upgrading or installing works remotely, see Upgrading GoldMine.

Read the following points before running an undocked computer installation:

■ If installing an Undocked version of GoldMine while it is in your office, disconnect the laptop from the network so
you install a completely independent copy on the computer.

■ An Undocked installation is performed for users that frequently work remotely and are not connected to the
office network via a faster connection. The user works on a local database on their computer. Data is
exchanged between the user’s local database and the office database during synchronization. For more
information, see the online help for instructions on setting up GoldSync.

■ Instead of using the following procedure, you can run the installation by using an installation file for One-Button
Synchronization. For further information, refer to the “Synchronization” chapter of the GoldMine
Administrator Guide (or the “Synchronization” topic in the online help).

Creating an Unattended Installation Script
During installation, you have the option to Create a configuration file for unattended installation (see Installation
on a Server). If you are planning on installing or upgrading GoldMine on other computers, you can, use this
file or create a new one

By creating a customized installation script, you can choose precisely the script parameter information you
want to proliferate to the other computers on your network. This script can then be used for your
unattended installations.

Use Case Scenarios
■ New Installation

Create installation file that enables GoldMine to be installed (with data and license) on an undockedmachine in
an unattendedmode. Repeat this process for 20 undockedmachines

■ New Installation Connecting to Existing Database
Create installation file that enables GoldMine to be installed (with data and license) on an networkedmachine
in an unattendedmode that connects to an existing database. The process is similar to a New Installation
above.

■ Upgrade Installation
Upgrade an undockedmachine with a new license. This process should not require that the administrator have
physical access to the machine. Repeat this process for any additional undockedmachines.
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To Create an Unattended Installation Script

1. Start GoldMine and login as an administrator.
2. Open the Toolsmenu and select Configure > System Settings.
3. Click the Script for unattended installation tab.
4. Open the drop-downmenu and select the installation type:

○ GM Upgrade from previous versions
○ New GM installation with connect to existing database
○ New GM installation with new database

5. Select or modify any Value for each Property as needed.
6. Click the Create button to generate the script.
7. ClickOK to close the System Settings dialog box.

The new script is saved to the \GoldMine\Setup\ directory.

Below is an example of the two files created:

○ NewGm-NewDb-X-000390-EVALNR-00000-00000-00000.ini

○ NewGm-NewDb-X-000390-EVALNR-00000-00000-00000.bat



Page 33 of 72

To Run an Unattended Installation Script
8. Create an Unattended Installation Script (see To Create an Unattended Installation Script).

9. Place a copy of the .INI and .BAT file in the same location as the GoldMine installation file.

For example, the following files would need to be in the same directory to run the script:

○ <scriptname>.ini

○ <scriptname>.bat

○ gmsetup.exe

10. Run the <scriptname>.bat file to start the installation.

Modifying the Registration Key
If you install GoldMine Plus!, it is only active for the current user. If you want other users of the same system
to have access to Microsoft integration features, you must make changes manually to the system registry for
each additional user. This change is only required for Excel. To make these changes, follow the steps listed
below.

To Modify the System Registry for Additional GoldMine Plus! Users
WARNING: You should create a backup of your Windows Registry before making any changes.

1. Login as different user account.
2. Open the WindowsStartmenu and select Run.
3. Type regedit in the textbox and clickOK.
4. Expand the tree to:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\<YOUR VERSION>\Excel

The <YOUR VERSION> Office folders are as follows:

○ For Office 2007 = 12.0
5. Expand the Excel folder.
6. Right-click onOptions and select New > String Value from the context menu
7. Name the new string OPEN.
8. Right-click the OPEN string and select Modify.
9. Enter the following string in the Value data textbox:

/A “GMPlusOffice2007.UserDefinedFunctions”

10. ClickOK to save the changes.



Licensing and Registration

Overview
GoldMine has a fully scalable licensing structure to meet the needs of individuals and organizations. As your
business matures and GoldMine expands, your organization can change the licensing configurations.

General Licensing Information
The single, distributed Master License serves as the authentication mechanism for secure synchronization
across the entire organization, and the LicenseManager keeps track of your licensing configurations.

Most organizations generally buy one license—aMaster License with x number of seats. These seats can
then be parsed to users in various combinations of sub-licenses. For example, an organization can create
Site sub-licenses for their remote office(s) and Undocked sub-licenses for individual remote (mobile or web)
users. One seat should always be set aside for administrators.

License Types
■ Master License: This is the primary license. It determines what database types are supported by the master

site as well as its synchronization capabilities. It is a precursor to executing any sub-licenses which stem from
it.

NOTE: GoldSync and Outlook Integration licenses are included in E licenses.

TIP: For information about licensing serial number schema, see License Serial Number.

■ Sub-licenses: To issue, install GoldMine with a Master License on your organization’s primary network. This
ensures all sub-licensesmaintain security and are authenticated properly during synchronization.

NOTE: The Undocked license (a special sub-license) is for remote users and can only be licensed
for a single user. It can be sub-licensed from the main GoldMine system or from a Site sub-
license.

■ Increases: Previous increases for Premium Edition, Corporate Edition, and GoldSync (J, R, and N), are now
facilitated by obtaining a new E license.

Master License

E Supports SQL databases and includes GoldSync

G GoldSync License GoldSync seat purchased separately and can be added to E-
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Licenses.

M GoldMine Mobile License Support for GoldMine Mobile users.

Sub-licenses

U Undocked License Single sub-license for a remote GoldMine user

S Site License Multiple-user sub-license for a remote office

Y GoldSync License GoldSync sub-license for a remote office

License Serial Number
The schema for the serial number has changed. Because of the new licensing schema, the GoldMine installer
will not upgrade your license. This example illustrates what a GoldMine license serial number looks like:

■ License type: Alpha-prefix denotes the type of Master license.
■ Number of users: First 4 numbers indicate the license count or seats available in the license. The license count

determines the number of users who can log on to GoldMine at one time but does not limit the total number of
named users.

■ Version: A 2-digit version number.
■ HDA number: A unique 6-digit customer account number, also referred to as the Help Desk Authorization (HDA)

Account.
■ Serial number: 15-character (alphanumeric) serial number uniquely identifying the license for an organization. It

is used for registration and support and identifies all sub-licenses as part of the same organization. Collected in
3 groups of 5 characters during licensing.

■ Key code: 15-character (alphanumeric) key code is a computer-generated check used by GoldMine to verify the
license’s validity. Collected in 3 groups of 5 characters during licensing.

NOTE: The license is required for the product to run. Keep the license number and key code in a
safe place in the event it becomes necessary to reinstall the software.
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License Manager
Initial licensing information is collected during installation. Subsequent changes and related management
functions are handled through the License Manager.

To open the LicenseManager, launch GoldMine, open the Toolsmenu and select Configure > License Manager.

The central text box lists all installed licenses and any sub-licenses created from this loc ation. Status is
displayed along the right side. Buttons along the bottom allow you to add a New License, add a New Site, add
an Undocked User, Remove License, or View License.

The database support of theMaster License is inherited by the site sub-licenses distributed throughout the
organization. GoldSync Synchronization capabilities can be distributed separately to sub-licenses.

NOTE: Licensing information is stored in the license file, LicenseGM94.bin, created at the time
you register. This file must exist only in the GoldMine root directory of each GoldMine installation.

TIP: Additional License Manager information is provided in the Online Help.

LicenseGM.bin File Locations

The LicenseGM94.bin file is location in the following directories per operating system:

Windows 2012 Server
Windows 2008 Server
Windows 8/8.1
Windows 7

\ProgramData\GoldMine
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Licensing with a Master License
A GoldMine Premium Edition Master License begins with the alpha-prefix E.

For Example: E-002594-123456-...

The E-license is usually a multi-user license for a Server installation of GoldMine, but can be a single-user
license for a Undocked Workstation computer.

An E-license includes a GoldSync license for each purchased GoldMine seat.

Remote site sub-licenses (S- and Y-licenses) and Undocked sub-licenses (U-licenses) are created from the E-
license.

Type the E-license number and key code you received when you purchased the software.

NOTE: If you type an E-license serial number into the text boxes, the GoldSync text box area
remains unavailable because GoldSync is included.

Licensing Following Installation
1. After the installation completes, click Finish. The licensing wizard launches.

NOTE: If you do not complete the license and registration information after installation, the
licensing wizard launches prior to first use of GoldMine.

The Enter GoldMine Serial Number dialog box appears.
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2. Type your GoldMine serial number and key code. Options appearing in this dialog box depend on type of license
purchased.

3. ClickNext. The Enter License Information dialog box appears.
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NOTE: The following fields are used in GoldMine when using address information for the
VCard (.vcf file):

- Mailing Address = Address1 (steet address) + Address2 (suite/room number)

- Home Street Address = Address1

This information can also be accessed from the Registration tab in the GoldMine License
Manager (Tools > Configure > License Manager). For more information, refer to the GoldMine
Online Help.

4. Enter your contact information in the designated text boxes to continue. All fields are required.
Click the checkbox if you want to receive future product information.

5. ClickNext. The Import Windows User Accounts dialog box appears.
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6. Select each user account you want to import into GoldMine. If appropriate, type an optional password for
imported names.

NOTE: Imported users do not have “master” rights.

7. ClickNext. The Enter Your Username dialog box appears.
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8. Type a user name (eight characters or fewer). The password is optional. GoldMine requests these at log in. This
user hasMaster Rights in GoldMine.

9. Click Finish. The GoldMine Logon dialog box appears.
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10. Type the user name and password and clickOK to launch GoldMine.
11. After logging in, the Universal Search dialog box appears.

IMPORTANT: Full Text Searchmust be installed and configured prior installing GoldMine Universal
Search.

12. Click Yes to proceed with Universal Search or No to ignore the option.
If you clickNo, Universal Search can still be installed at a later time. For more information, see “About Universal
Search” in the GoldMine User Guide or Online Help.

Creating Sub-licenses
After GoldMine is installed and licensed, you can parse seats to your end users with sub-licenses using the
LicenseManager. You must have a Master License to create sub-licenses.

IMPORTANT: Plan before creating sub-licenses, keeping in mind each sub-license transfers seat
availability which affects how many users can log in on the network system. For example, on the Licenses
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tab of the License Manager, if the Total users/dist: shows a total number of seats and the total number of
sub-licenses as “50\20,” only 30 seats are available to users. At a minimum, one seat should always be set
aside for administrators only.

Creating Sub-licenses for Remote Offices
From a Master License, you can create sub-licenses for remote offices. Remote office sub-licenses can be a Site
License (S-license) and/or a GoldSync License (Y-license).

Each “S” sub-license transfers seat availability from non-remote users. Aminimum of one seat must remain
available to non-remote users. For example, you must have at least 5 seats to make GoldMine available to 4
remote offices. Headquarters retains the fifth seat.

NOTE: When creating any sub-license, note the entire license number created by GoldMine. The
sub-license includes the key code and additional information needed when licensing the remote
computer.

To Create a Sub-license for a Remote Office
1. From the GoldMinemenu, select Tools > Configure > License Manager. The License Manager appears.
2. Click the Licenses tab.
3. ClickNew Site. The Create a Site Sub-License dialog box appears.

4. In the Distributed License Type area, select the site license you want to create; GoldMine Site License (S-
License)for the number of seats the site needs or GoldSync Site License (Y-License) for the number of users who
are synchronizing, including at least one for the site.

TIP: Write the sub-license number down or copy it toWindows Notepad. The sub-license number is
needed for each remote computer installation. Send the remote site license number to the
remote user who can type the license number during the GoldMine installation.
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5. In the Site Sub-License area, type the site name and number of users.
6. Click Create Site Sub-License. The Site-License for Remote Site dialog box appears.
7. Review the information about the sub-license and click I Agree. The sub-license number for the site appears in

the Sub-license for Remote Site [Name of Site] dialog box.
8. If you created a Site license, repeat the above process to create the necessary GoldSync license and select

GoldSync Site License.

NOTE: GoldMine adds the sub-license to the list of licences on the Licenses tab of the License
Manager.

Creating Sub-licenses for Undocked Users
GoldMine has a sub-license for an individual user called an Undocked License (U-License). This license type is
created for users who work primarily with GoldMine at a remote location on a laptop, notebook, or home
office computer but who may also need to log on to the network occasionally. Consider:

■ Creating an undocked user decreases the available users of the network site (Master License or Site License) by
one; however, when an undocked user logs on to the site from which they were sub-licensed, they do not take
up an additional seat.

■ Every user supported by the GoldMine license can have an Undocked license to work on a remote computer. For
example, on a 5-user GoldMine system, 5 Undocked licenses can be created. This is in contrast to creating an
“S” sub-license which requires one seat to remain available from the Master License.

■ All undocked users, as well as the total number of users that make up the difference in the total number allowed
by the Master License can log on to GoldMine. For example, on a 5-user GoldMine system with 3 undocked
users, 3 undocked users plus 2 other users can log on to GoldMine.

WARNING: If you undock all users, only those users will be able to log in. If you have not assigned
master rights to any of those undocked users, GoldMine administration cannot take place.

■ When used in combination with GoldSync, administrators can synchronize security settings to undocked users
including new passwords, menu items, and preferences in addition to data.

■ To work on an undocked basis, users must have an Undocked license on their laptop. Create an Undocked license
from the Master License or a Site license.

To Create a Sub-license for an Undocked User
1. From the GoldMinemainmenu, select Tools > Configure > License Manager. The License Manager appears.
2. Click the Licenses tab andUndock Users. The Create Undocked User Licenses dialog box appears.
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3. Select the check box next to the user you want to create a sub-license for, and click Create Undocked License.
The Sub-Licenses dialog box appears.

4. Review the information and click I Agree. The sub-license number for a remote user or an undocked user
appears in the Sub-license for Remote Site [Name of Site] dialog box.

TIP: Write the sub-license number down or copy it toWindows Notepad. The sub-license number is
needed for each remote computer installation. Send the remote site license number to the
remote user who can type the license number during the GoldMine installation.

Licensing with Sub-licenses

Site License
A Site License is a multiple-user sub-license for a remote office and is designated with the alpha-prefix “S.” You
should have an S-license for each user at the remote site.

A GoldSync License (Y-license) is required only if you are using an S-license and want to synchronize using
GoldSync. You should have one Y-license to synchronize with theMaster License and additional Y-licenses for
Undocked users synchronizing with your site.

NOTE: Y licenses are not entered in the Enter GoldMine Serial Number dialog box. Only S licenses
are entered during registration (the GoldSync Section remains disabled). Clicking Next displays an
ALERT: Suggested Action(s)! if you try to enter Y licenses in the Enter GoldMine Serial Number
dialog box.

If this installation of GoldMine includes its own GoldSync sites, you may enter the applicable Y-type sub-
licenses to properly configure synchronization for this system.

1. To configure applicable sub-license sites, select Tools > Configure > License Manager to enter your Y-type
license.



Page 46 of 72

2. In the GoldMine Serial Number text boxes, type the S-license, Key Code, and Site Code you created in the
License Manager of the main GoldMine system.

3. In the GoldSync Serial Number text boxes, type the Y-license, Key Code, and Site Code you created in the License
Manager.

Undocked License
Undocked licenses are sub-licenses created from a Master License or a Site license and are designated by the
letter “U.” This license type is created for users who work with GoldMine at another location, on a laptop, or
on a workstation disconnected from the server copy of GoldMine.

Type the U-license, Key Code, and Site Code created in the LicenseManager.

Evaluation License
The Evaluation license allows you to evaluate GoldMine Premium Edition for 30 days. During or after this time
you can purchase a production GoldMine license and apply it to your database.

You will receive a warning of the approaching expiration of the evaluation license. If you do not apply a
production license within 30 days, product performance will degrade to make GoldMine unusable for practical
use, but will permit an administrator to access the application to add a license or re-evaluate the user
interface.



Upgrading GoldMine

The upgrade process is intended to be used with GoldMine 9.0.0 or higher. There is no need to uninstall the
existing version, or remove folders and databases before proceeding. If you are upgrading a prior version,
you must upgrade to 9.0.0 before upgrading to the latest version. Contact Customer Care at 800.776.7889
for information about upgrading from versions prior to 9.0.0.

NOTE: Back up your existing GoldMine database and system before beginning the upgrade.

■ A database conversionmight be required when upgrading from earlier versions of GoldMine. This conversion
occurs automatically when GoldMine is installed into the path of the existing gmw.exe.

IMPORTANT: If you are upgrading a large Microsoft SQL Server database (5GB of data
or more), note that certain computers (limited computing power) require manual steps to
upgrade the database successfully.

■ Undocked users must be on the same version and build of GoldMine as the site with which they sync. If you are
upgrading the server but are not upgrading UndockedWorkstations until a later time, disable their sync sites
in the GoldSync Administration Center on the server. Reactivate their site when the undocked computer is
upgraded and is running the same version and build of GoldMine as the server.

■ Ensure you have adequate disk space available prior to installation.

NOTE: If your company policy requires that you uninstall the previous version of GoldMine to run
a “clean” installation, youmight have entries left in the Windows Registry which will cause
GoldMine to assume you are upgrading. These entries must be removed to allow you to install
GoldMine. Consult with your System Administrator before you attempt to remove any entries
from your Windows Registry.

Upgrading Existing GoldMine Running SQL Server
The following procedure demonstrates upgrading from a SQL Server 2005/2008 Standard Edition database.
This procedure is for customers who have the following:

■ GoldMine 9.0.0 or newer
■ SQL Server/SQL Server Express GoldMine database

If you are upgrading from a previous version of GoldMine and have a large Microsoft SQL Server database
(5GB of data or more), refer toMigrating Large Databases.

IMPORTANT: Before upgrading GoldMine, we recommend backing up your existing database.
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To Upgrade GoldMine Running SQL Server
1. TheWelcome to the GoldMine InstallationWizard dialog box appears.

2. ClickNext. The Readme dialog box appears.
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This file contains the most recent information about this version.

3. Close this dialog box after reviewing the most recent information about this version of GoldMine to proceed
with the installation.

4. The License Agreement dialog box appears.
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5. Review the licensing information carefully; if you agree to the terms, select I accept the terms in the license
agreement.

NOTE: If you do not agree to the terms of the license agreement, select I do not accept the
terms in the license agreement. Click Cancel to terminate the installation.

6. Accepting the terms of the agreement activates the subsequent check boxes. Youmust select both check boxes
to continue with the installation.

NOTE: Select I am an authorized agent and/or representative of the customer/end-user and I
have read the terms and conditions stated above to continue.

7. ClickNext. The Custom Setup dialog box appears.
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The GoldMine Premium Edition and GoldMine Plus! options are selected for installation by default. There are
three options under the GoldMine Plus! option:

○ For Microsoft Word
○ For Microsoft Excel
○ For Microsoft Outlook
If you do not want to install the GoldMine Plus! components, click the GoldMine Plus! icon, select This feature
will not be available from the drop-downmenu, and then clickNext. Alternately, can select individual GoldMine
Plus! components for exclusion during installation.
These components can be install at a later date using the Add or Remove Programs control panel inWindows,
and then selecting Change for the GoldMine entry on the list.

8. To install the selected GoldMine features, clickNext.

NOTE: Microsoft Office must be installed prior to installing GoldMine Plus! components.

9. ClickNext. TheMS SQL Administrator Login dialog box appears.
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The Server Name, Database Name, and Database Owner fields are retained from the previous installation and
not required during the upgrade. The only fields required in this dialog box are:

○ MS SQL Administrative Username:The default login is sa. If your SQL Server user name is different, your SQL
administrator must provide the information.

○ MS SQL Administrative Password:Enter the SQL Server administrator password.

NOTE: If you clickNext without typing a user name and password, the Insufficient Input dialog box
appears. Click Back. If you type incorrect information and clickNext, theMS SQL Login Failed dialog
box appears. Review the troubleshooting tips, then click Back.

10. ClickNext to continue.

IMPORTANT: A minimum ofMicrosoft SQL 2008/2012 Express with Advanced Services is required for the
GoldMine database. SQL Express editions have a maximum database size:

- SQL Express 2008/2012/2014 = 10 GB

11. The Ready to Install the Program dialog box appears.
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If you will be installing GoldMine on other computers sharing these same configuration settings, you can check
the Create a configuration file for unattended installation box to create a configuration file with these settings.
A GoldMine administrator can also create unattended installation scripts for various installation scenarios (see
To Create an Unattended Installation Script).

12. Click the Install button.
13. If you selected any of the GoldMine Plus! options, a Question box appears.

14. Click Yes to install the Microsoft Office add-ins, or clickNo to skip installation of these add-ins and only install
GoldMine.

15. The Installing GoldMine dialog box appears.
16. When finished, the Installation Completed dialog box appears.
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17. Click Finish to start GoldMine.
18. Enter your login information. GoldMine updates your database and starts the program.

NOTE: If you are upgrading from a previous version of GoldMine that supported Dashboards, a
message box displays asking if you want to overwrite the existing predefined Dashboards. Click Yes
to overwrite or No to keep your existing predefined Dashboards.

Upgrading Remote Systems
This type of upgrade is for computers working disconnected from a Server but synchronizing with the main
Server to update GoldMine information: a remote Site or an Undocked Workstation computer.

■ If you are upgrading a Site, the Master installation provides the site administrator with the gmsetup.exe. For
more information, see Installation on a Server.

■ If updating an undocked computer, the Master installation provides the undocked computer user with the
gmsetup.exe. For more information, see Installation on an Undocked Computer.

■ If you are upgrading the server but are not upgrading a remote system until a later date, disable the site in the
GoldSync Administration Center until it is running the same version of GoldMine as the server.

To Upgrade a Remote System
1. Upgrade the Master GoldMine site.

2. Upgrade remote computers by sending them a gmsetup.exe installation file using one of these methods:
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○ CD-ROM
○ FTP site
○ E-mail
○ Accessible network drive

NOTE: Database upgrade and universal search installation are automatic when the user selects the
Yes option. If the user selects not to install Universal Search, it can be installed later by running
GoldMine with a special parameter: GMW /us:install (see Installation of Universal Search).

3. Remote users must run the installation CD or the gmsetup.exe on their computer following these upgrade
instructions.

After remote users upgrade to the same version of GoldMine as the server, they can begin synchronizing
again.



Configuring

After installation, system administrators must configure GoldMine to meet the needs of the organization.
Some preliminary setup is presented in this chapter. Additional configuration steps are presented in the
online Help.

Configuration Considerations
In developing a GoldMine deployment strategy, the GoldMine administrator must carefully plan how the
GoldMine database should run and determine who is going to use it.

■ Creating users, user groups, security rights, and preferences including menu rights
■ Changing field labels
■ Creating user-defined fields and tabs
■ Setting up expanded details
■ Generating andmodifying F2 Lookup lists

To Enhance GoldMine, Configure Other Areas:
■ Automated Processes
■ Reports

To Import Existing Databases Into GoldMine, Plan the Migration by
Asking Yourself:

■ Is it essential to keep all existing data?
■ How out of date is the data?
■ Are all fields in the existing database required in GoldMine?

TIP: For details on these procedures, see the Administration topics in the GoldMine online help
Table of Contents, accessed by selecting Help > Help Topics on the GoldMine menu bar.

Placing a Custom Image in the Logon Window
To display your organization’s logo or other graphic on GoldMine’s logon screen correctly, the file must be a
bitmap within a size limit of 150 x 250 pixels.
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NOTE: GM.ini is a special initialization file that stores settings that apply globally to all users
running the same installation of GoldMine.

Place the bitmap file in the root GoldMine directory. Using a text editor such as Windows Notepad, open
GM.ini. Under the [GoldMine] section, add this line:

UserLogo=<path\<filename>

For example, if you place the graphics file MyLogo.bmp in your GoldMine directory, type this statement:

UserLogo=C:\GoldMine\MyLogo.bmp

Save GM.ini, then exit the text editor. Open GoldMine to display the changed login screen.



Installing Microsoft SQL Server

The Server setup requires that you install Microsoft SQL Server before installing GoldMine. Microsoft SQL
2008 is recommended and used as the example in this section. For information about installing earlier
versions, refer the documentation that came with your version.

The following instructions include installation procedures and settings pertinent to GoldMine but should
not be considered a SQL Server administrator’s guide. Only experienced SQL administrators should
configure SQL Server with anything other than the settings described in these instructions.

TIP: The Microsoft SQL Server 2008 CD included with your GoldMine Premium Edition package
provides complete installation instructions in the Microsoft online help.

Installing Microsoft SQL Server 2008
The server on which you are installing Microsoft SQL Server 2008must have one of the following operating
systems: Windows Server 2008 Enterprise, Standard, or Data Center Edition; Windows Small Business
Server 2008.

NOTE: For detailed hardware and software requirements for installing SQL Server 2008, refer to
http://msdn.microsoft.com/en-us/library/ms143506.aspx.

1. Insert the Microsoft SQL Server 2008 Installation CD into the CD/DVD drive of the computer on which you are
installing SQL Server.

NOTE: The SQL Server 2008 Installation CD is set up to autorun when inserted into your CD/DVD
drive. If autorun is not enabled, select Run from the Windows Startmenu on the Windows
taskbar, and then type x:\setup.exe (where x is the letter of the CD/DVD drive).

The SQL Server Installation Center opens.
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2. From the menu list on the left, select Installation. The screen changes to display the installation options.

3. From the list of installation options on the right, select New SQL Server stand-alone installation. The SQL server
2008 Setup dialog box opens.
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4. Prior to installing SQL Server Support files, the wizard runs an operation to identify problems that might occur
when installing the support files. If problems are indicated, they must be resolved before the installation
process can continue. If no problems are identified, clickOK to continue. The Product Key dialog box opens.

5. The product key information should be auto-populated. ClickNext. The License Terms dialog box opens.
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6. Read the licensing agreement and check the I accept the license terms box to indicate agreement. ClickNext.
The Setup Support Files dialog box opens.

7. Click Install. The operations runs to install the Setup Support Files. This may take several minutes.
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8. When complete, clickNext. The Feature Selection dialog box opens.

9. Select the Instance Features: Database Engine Services, Full-Text Search, Client Tools Connectivity, and also the
Management Tools option (either Basic or Complete). ClickNext. The Instance Configuration dialog box opens.

NOTE: If you plan on using Reporting Services with GoldMine, Reporting service must also be
installed.
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10. Select the Default instance option and clickNext. The Disk Space Requirements dialog box opens.

11. ClickNext. The Server Configuration dialog box opens.
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12. Change the SQL Server Agent Startup Type to Automatic, then click the Use the same account for all SQL Server
services button. A dialog box opens for you to select the Account Name: select NT AUTHORITY/SYSTEM. Click
OK.

13. ClickNext. The Database Engine Configuration dialog box opens.

14. Select theMixedMode option, then enter and confirm the password. Youmust also specify a SQL Server
Administrator; you can click the Add Current User button to do so.

15. ClickNext. The Error and Usage Reporting dialog box opens.
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16. If you want MSSQL Server 2008 to automatically send your error messages and usage reports toMicrosoft,
check the appropriate box. ClickNext. The Installation Rules dialog box opens.

17. ClickNext. The Ready to Install dialog box opens.
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18. Review the installation summary, then click Install. The Installation Progress dialog box opens.
19. When installation is complete, clickNext. The Complete dialog box displays, advising you to restart you

computer.
20. Click Close, then restart your computer.
21. Exit the SQL Server Configuration Manager.
22. InWindows, go to Start > Settings > Control Panel > Administrative Tools > Computer Management.
23. Expand Services and Applications and select Services.
24. Stop and restart the service SQL Server (MSSQLSERVER).

Post-Installation Configurations
Subsequent to installing SQL Server 2008 and GoldMine, you will need to open Microsoft Server SQL
Management Studio to confirm (or modify) the configuration of some database settings:

1. Open the WindowsStartmenu and select Programs > Microsoft SQL Server 2008 > SQL Server
Management Studio.

2. In the left panel, clickDatabases to open the folder, then right-click your database, and select Properties.
3. In the Select a page panel, clickOptions.
4. Confirm the Recovery model field is set to Full.

NOTE: This might greatly increase the database size and transaction logs. Transaction logs should
be regulary backed up and truncated to save space.

5. Confirm the Compatibility level field is set to the highest level.
6. In the Automatic section, confirm the Auto Create Statistics is set to True.
7. In the Automatic section, confirm the Auto Update Statistics is set to True.
8. ClickOK.



Page 67 of 72

Troubleshooting
If you receive an error message such asMSSQL Login Failed during the installation of GoldMine, check the
following:

■ Is the SQL server running? If not, start SQL Server.
Open the MSSQL Enterprise Manager and find SQL Server Enterprise Manager. Expand the servers until you see
your server name. Right-click your server name and select Start in the local menu.

■ Is the SQL administrative name and password you typed when installing GoldMine different from the name
and password in SQL? Are you using sa with no password, or did you change the password in SQL?
Open the SQL Server Enterprise Manager. ExpandMicrosoft SQL Server and then expand SQL Server Groups.
Right-click your server name and select Edit SQL Server Registration properties. Verify the login name and
password.

■ When you installed SQL, did you select Mixed Mode for the authentication mode?.
If you do not know, go to the server name in the MSSQL Enterprise Manager. ExpandMicrosoft SQL Server and
then expand SQL Server Groups. Right-click your server name and select Properties. Select the Security tab.
Select SQL Server andWindows. Stop and restart SQL Server. The installation continues.



Migrating Large Databases

If you are upgrading from a previous version of GoldMine to version 2015.1 and have a large Microsoft SQL
Server database (5GB of data or more), we recommend you consider the following steps before proceeding
with the upgrade. Certain computers (limited computing power) require manual steps to upgrade the
database successfully.

Database Preparation

Back Up Your Database
This is especially important prior to migration. Also, a power failure or any unpredicted interruption may
corrupt data. Invaluable data can be restored from the backup.

Truncate the Transaction Log
For SQL 2008 or SQL 2012

1. From Start, selectMicrosoft SQL Server > SQL Server Management Studio.
2. After logging on to SQL Server, click the New Query toolbar button (or select File > New > Query with

Current Connection).
3. Run:

Alter Database dbname Set Recovery Simple

Alter Database dbname Set Recovery Full

4. Purge the syslog table from your current GoldMine version. Ensure you have backed up your database prior
to purging.

■ To purge logs, select Tools > Logs > GoldMine Logs. The System Logs dialog box appears. Select either
Process Monitor Logs,Maintenance Logs, or Error Logs. Right-click and select Purge Logs.

■ Select the check boxes for Process Monitor,Maintenance, and Error logs. Accept the default date (1 month)
or adjust to extend. If you require more logs, revise according to the GoldMine Online Help or the GoldMine
Administrator Guide.
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