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Introduction

GoldMine Premium Edition provides a powerful, comprehensive, integrated, automated solution tomanaging
customer relationships. It contains tools to develop contacts, conduct activities, and track progress. With
GoldMine’s synchronization features, users working remotely can have their own database of desired data and
keep it updated with the company database. GoldMine can also synchronize with Outlook and Google Apps
Calendars.

GoldMine Connect allows you to use selected features of GoldMine Premium Edition via a web browser.

This guide describes the basic components and steps for installing GoldMine Premium Edition and provides
information about integrating GoldMine with your other technology tools.

About this Guide
The GoldMine Premium Edition Installation Guide describes the basic components and steps for installing
GoldMine Premium Edition on your Server, NetworkedWorkstations, and UndockedWorkstation, and helps you
integrate GoldMine smoothly with your other technology tools.

Audience and Expertise
This information is pertinent for users and system administrators performing installations. It describes the system
requirements, and contains step-by-step installation instructions and tips for server setup, workstation setup, and
undocked user installations.

This material assumes that the user understands how to use the Microsoft Windows operating system for
installations.
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System Requirements

This chapter provides the GoldMine system requirement information you need before you begin a Server,
NetworkedWorkstation, or UndockedWorkstation installation.

NOTE: Before installing GoldMine, review the most current version of the compatibility matrix
document available in our Knowledgebase. Seewww.GoldMine.com/goldmine-support/ to
access the Knowledgebase.

Permissions

GoldMine
■ Only users with local Administrator rights, or users who belong to the Administrator group, can install

GoldMine.
■ The MS SQL Administrative Username must have permissions to create a new database (for new installations

only).

GoldMine Plus!
■ Youmust have Windows administrator permissions when you install GoldMine Plus for Microsoft Office, in order

for GoldMine Plus to be available globally for all users.
■ GoldMine Plus! must be installed under the user profile of the user that will have the integration.

Environments
Pay particular attention to the system requirements that apply to your environment and license type.

GoldMine can be installed and run in various environments. For example, you can install GoldMine on a dedicated
Server, or select a regular computer running a server operating system to host a server installation (see Server
Requirements). Environment is influenced by database size and capabilities, performance considerations, number
of shared/undocked users, etc.

Host Requirements
Requirements are listed for the following:

■ Server Requirements
■ Workstation System Requirements
■ Undocked Workstation Requirements
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Software Requirements
■ Microsoft Internet Explorer 9.0 or newer
■ Microsoft Windows Installer 4.5 or later (may require server restart).

Server Requirements

Operating Systems
HEAT Software supports these operating systems for the GoldMine Application Server:

■ Microsoft Windows Server 2012
■ Microsoft Windows Server 2012 R2
■ Microsoft Windows Server 2008 R2
■ Microsoft Windows Server 2008

If you are using Microsoft Small Business Server 2008 or 2011 or Windows Server 2012 0r 2102 R2 Essentials, it must
be installed and working prior to installing GoldMine. Ensure that SQL Server and SBS service packs are current and
applied.

Network Protocols
■ TCP/IP (recommended)

Database Requirements
NOTE: Ensure that the SQL edition and version are compatible with the Microsoft Operating
System used at your installation.

■ Server Database (must be installed and configured)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2008 SP2
○ Microsoft SQL Server 2008 R2
○ Microsoft SQL Server 2008 R2 SP1
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014

■ Reporting Services (must be installed and configured to use the Scheduled Reports feature)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014

■ Full Text Search (must be installed and configured to use Full Text Search feature)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014
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■ Client Tools (must be installed prior to initiating the GoldMine installation process if you intend to perform a
Server installation to share your database.)

○ Microsoft SQL Server 2008
○ Microsoft SQL Server 2012
○ Microsoft SQL Server 2014

IMPORTANT: SQL Express 2008, 2012, and 2014 have amaximum database size of 10 GB. Advanced Services
must be installed in order to use Microsoft SQL Server Reporting Services.

Additional Server System Requirements
■ SCSI or Ultra DMA Enhanced IDE hard drives: RAID Array or mirrored (recommended).
■ 1GB/100 MBps network connection (recommended).

Server Memory Requirements
NOTE: The following table lists recommended RAM allocations. Your actual RAM requirement can
vary depending on other Performance Considerations. Insufficient RAMmight cause you
machine to process data more slowly.

Database Size Minimum RAM Allocation

50 MB 128 MB

100 MB 256 MB

500 MB < 2 GB 512 MB

2–5 GB 1 GB

5–12 GB 2 GB

12+ GB 3 GB

NOTE: Youmight also need to increase your RAM allocation when using Universal Search and Full
Text Search in GoldMine.

Performance Considerations
The amount of RAM you have in your Server and the CPU speed requirements vary depending upon your database
size and these factors:

NOTE: These factors are in addition to the database size and RAM recommendation listed in the
table for Server Memory Requirements. For example, if you have 2 GB of mailbox records, you
would need to increase the RAM tomatch the recommendations accordingly.
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■ Number of items in the database:

○ Contact Records (1 KB each)
○ Detail Records (2 KB each)
○ History Records (1 KB each)
○ User-defined fields

■ Number of simultaneous users on the network
■ Database size
■ Mailbox records (often the largest table andmost used)

Workstation System Requirements
NOTE: HEAT Software neither supports nor recommends using Windows emulators onMacintosh,
Linux, or other operating systems.

Operating Systems
This release of GoldMine Premium Edition supports the following operating systems for the GoldMine
Network Clients. Refer to the Compatibility Matrix for specific information.

■ Microsoft Windows 10
■ Microsoft Windows 8 and 8.1
■ Microsoft Windows 7

Hardware Requirements

Operating System CPU (Intel or AMD) RAM

Microsoft Windows 10 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Microsoft Windows 8 & 8.1 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Microsoft Windows 7 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)
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Undocked Workstation Requirements
The following recommendations are made for computers operating when disconnected from a Server.

Operating Systems
HEAT Software supports these operating systems for the GoldMine Undocked Clients:

■ Microsoft Windows 10
■ Microsoft Windows 8/8.1
■ Microsoft Windows 7

NOTE: HEAT Software neither supports nor recommends using Windows emulators onMacintosh,
Linux, or other operating systems.

Hardware Requirements

Operating System CPU (Intel or AMD) RAM

Microsoft Windows 10 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Microsoft Windows 8 and 8.1 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Microsoft Windows 7 3.0 GHz or faster
2 GB RAM (3GB or more RAM
depending on your database)

Performance Considerations
The amount of RAM you have in your Workstation and the CPU speed requirements vary depending upon
your database size and these factors:

■ Number of items in the database:

○ Contact Records (1 KB each)
○ Detail Records (2 KB each)
○ History Records (1 KB each)
○ User-defined fields

■ Number of simultaneous users on the network
■ Database size
■ Mailbox records (often the largest table andmost used)
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Additional Requirements
■ Microsoft .NET Framework 3.5 (which includes 2.0 and 3.0) must be installed and enabled inWindows Features to

use the Scheduled Reports feature..
■ Microsoft .NET Framework 3.5 (which includes 2.0 and 3.0) must be installed and enabled inWindows Features to

use GoldMine Plus! for Microsoft Office.
■ Microsoft .NET Framework 4.5 is required for installation of GoldMine Premium Edition. If it is not found, it will be

installed automatically.

■ Microsoft Visual Studio 2008 .NET (for use withMS SQL 2008) must be installed and configured to create reports
for the Scheduled Reports feature. End users do not require this application.

GoldSync Requirements
GoldSync automates the synchronization of data between a host GoldMine system andmultiple remote GoldMine
systems.

GoldSync supports multi-user/multi-site environments and includes support for many simultaneous connections. As
the amount of data and number of users increase, GoldSync scales as needed for the workload demand.

TIP: For details on GoldSync implementation and functionality, see “About GoldSync" in the Online
Help.

GoldSync System Requirements

Item Recommended

o Operating System

Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2008

o Disk Subsystem RAID Array or mirrored (for larger databases or heavy synchronization load)

o RAM Allocation 1 GB (for < 2 GB database with 10 concurrent sync sessions)

o Network Connection
100 Base-TX
TCP/IP



Installing GoldMine

GoldMine provides various types of installations, a new installation or upgrade, on a server or workstation, in
network or remote location. Review the planning items and considerations, determine the type of installation you
are running, and use the associated checklist to ensure a successful installation.

Planning Your Installation
When planning a GoldMine installation consider:

Who will be the designated GoldMine administrator? The GoldMine administrator must have access to
network and office resources and be able to address the business-related implementation issues regarding
configuration and customization.

Do you have the proper license and registration information for the version of GoldMine you are
installing? For detailed information on licensing, see Licensing and Registration.

TIP: GoldMine Solutions Partners are GoldMine Certified in installation and setup. To locate a
partner in your area, go towww.goldmine.com and use Find a Partner.

Are you going to import data? Verify that you can import the source data into GoldMine.

Does the system administrator have full administrative rights? To install GoldMine on a network, the
GoldMine administrator must have full administrative rights on the network.

Are your service packs compatible and current? Check the version and service pack number for your
Microsoft Windows operating system. Verify no issues exist with your current service pack.

Have you reviewed the network structure?
○ Are there multiple domains? Do users have the rights on the GoldMine domain to access GoldMine?
○ Is the server outside the regular network? There may be connectivity issues the network administrator

needs to address.

What type of database are you using? GoldMine supports bothMicrosoft SQL Server or SQL Server Express.

Will you be integrating GoldMine with Microsoft Office?Microsoft Office 2007/2010/2013/2016 are
supported for integrating with GoldMine, andmust be installed/configured before installing the GoldMine Plus!
component.

NOTE: GoldMine does not support the Microsoft Office 64 bit versions.
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Installation of GoldMine on Windows 7, Windows 8 or 8.1, or
Windows 10

■ You can install and run GoldMine onWindows 7,Windows 8 or 8.1, or Windows 10, but you cannot share your
installation with other NetworkedWorkstations over a network (i.e. they are not supported as application
server environments).

■ The installer will offer customized path settings for GoldMine's program files. The installer, by default, creates the
destination folders with correct permissions set for proper use. If the destination folders you will install to
already exist, or if you create them yourself, youmust ensure that the selected folders have the correct access
permissions.

NOTE: Installing to the default path is highly recommended.

Installation of Universal Search
The Universal Search feature provides a single view to quickly find out what information is in your system and how to
navigate to it. Universal Search can be installed by selecting Yes at the end of the Licensing Wizard (see Licensing
Following Installation), or by using one of the following procedures:

■ To Install Universal Search fromWithin GoldMine
■ To Install Universal Search from a Command Prompt

IMPORTANT: MS SQL Full Text Searchmust be correctly installed and configured prior installing
Universal Search.

For information about using Universal Search, refer to the “Universal Search” topic in the GoldMine Premium
Edition User Guide pdf or in the Online Help.

To Install Universal Search from Within GoldMine
1. Logon to GoldMine as user withMaster rights.
2. Open the Toolsmenu and select Configure > System Settings.
3. Click the Advanced tab.
4. Click the Install button.
5. Click the Yes button.
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To Install Universal Search from a Command Prompt
1. Logon to GoldMine as an administrative user when prompted for logon data
2. Open the WindowsStartmenu and select Run.
3. In the Open textbox, type gmw /us:install and then clickOK.
4. Login to GoldMine as an administrative user when prompted for logon data.
5. Install Universal Search by selecting Yes in the Do you want to install Universal Search?message box.

Searching E-mails in Windows 7, Windows 8 / 8.1 or
Windows 10

There is an issue when searching information in emails that occurs only when GoldMine is installed onWindows 7,
Windows 8/8.1, or Windows 10.

After installing Universal Search youmight see the following messages:

■ Message in the Application Event log:
Errors were encountered during full-text index population for table or indexed view '[gm81_35].[dbo].
[MAILBOX]', database 'gm81_35' (table or indexed view ID '309576141', database ID '20'). See full-text crawl
logs for details."

■ Message in the full text log:
"2009-09-12 19:12:30.13 spid18s Error '0x8007007e' occurred during full-text index population for table or
indexed view '[gm81_35].[dbo].[MAILBOX]' (table or indexed view ID '309576141', database ID '20'), full-text
key value 0x354C4F4A583248263B3F563D20573C. Attempt will be made to re-index it.
2009-09-12 19:12:30.13 spid18s The component 'MSFTE.DLL' reported error while indexing. Component path
'C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\MSFTE.DLL'

To fix this condition, perform the following procedure.

WARNING: It is recommended that you create a backup of your Windows Registry before making
any changes.

1. Find the registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{5645C8C2-E277-11CF-8FDA-00AA00A14F93}

2. Change the default value from
(%systemroot%\system32\mimefilt.dll) to (c:\WINDOWS\system32\mimefilt.dll)
where %systemroot% is the path where Windows is installed.

3. Restart the computer (or at minimum restart the Microsoft SQL Server).
4. Restart the Microsoft Fulltext service
5. Re-install the Universal Search (see Installation of Universal Search).
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After installing Universal Search youmight see the following message:
“You can see this message only in the Application Event Log”

System Files
Located in either the GoldMine Program Files folder or the GoldMine ProgramData folder, these files store user and
licensing information. System files typically have a .BIN, .XML, or .INI file extension.

■ DataDict.xml includes database and field definitions for creation of required databases andmaintenance
operations.

■ flags.bin controls the number of users logged on to GoldMine.
■ LicenseGM94.bin stores License Manager information and validates incoming sync connections.
■ USER_info.bin stores SQL login information.
■ GM.ini controls how GoldMine launches.
■ dbalias.ini stores the database username and password.
■ gmbase.bin is used tomaintain system integrity.
■ gmexp.bin stores revoked licenses.
■ SyncLock.bin is used tomaintain system integrity.
■ USER.ini stores how GoldMine launches for the user.

System Files for Supported Operating Systems
When installing GoldMine onto: Microsoft Windows 7,Windows 8,Windows 8.1,Windows 10,Windows Server 2008,
Windows Server 2008 R2,Windows Server 2012, or Windows Server 2012 R2 system, a split-path installation is used
due to security changes in these versions of Window’s architecture. The split-path installation will place executables
and program libraries into C:\Program Files\GoldMine (32-bit OS) or C:\Program Files (x86)\GoldMine

(64-bit OS), while data files, .INI files, reports, and templates are placed in \ProgramData\GoldMine.

NOTE: It is highly recommended that you install to the default paths.

Installation Checklists
If you are: Then run:

NetworkedWorkstation:An individual in an organization with a multi-user
environment whomust connect to a shared copy of the GoldMine database. Install
GoldMine on the client workstation so the end user can connect to the server copy
of the GoldMine database from his or her individual computer.

Full Setup, connected
to an existing database

UndockedWorkstation:An individual who often works remotely on a computer with
an Undocked sublicense, who synchronizes with a Server to update information.
Install a full copy of GoldMine with a database on a computer working disconnected
from a network.

Full Setup
(with U-License)
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If you are: Then run:

GoldSync Server: This can be also the Server and does not need to be an extra
machine.

Full Setup, connected
to an existing database

Server:A company that must support multiple GoldMine users using a shared
system. Users can then connect to the server copy from their local Networked
Workstation using shortcuts installed by running a Workstation installation.

Full Setup, Installed
First

Server Installation Checklist
Back up your database and folders: (Upgrading customers only) If you are upgrading, back up your GoldMine
database. We also recommend backing up your GoldMine program and data folders and any other folders
containing files linked to GoldMine before beginning any installation. This prevents the loss of valuable information
and data.

Confirm all GoldMine users are logged out of the system: (Upgrading customers only).

Uninstall linked and integrated programs: (Upgrading customers only)

Exit all running system programs and stop services: Includes third-party utilities that integrate with GoldMine, other
GoldMine add-on products (such as GoldSync), the Microsoft Office Shortcut bar. Stop all services that integrate with
GoldMine if applicable.

Install ancillary programs: Install necessary programs on the computer serving as the Server or on another computer
on your network (see Additional Requirements). On an Undocked machine, MS SQLmust be installed prior the
GoldMine installation.

Install GoldMine: Install on the computer serving as your Server. Select the Server Setup installation and follow the
directions in this manual.

License the server copy of GoldMine: Licensing registers the Server copy of GoldMine with the appropriate license
(see Licensing and Registration).

Verify you can launch GoldMine: Ensure the server installation is functioning properly before installing any
NetworkedWorkstation.

Share the GoldMine folder: In order for the NetworkedWorkstation to connect to the shared copy of GoldMine, you
must first share the C:\ProgramData\GoldMine folder. The location of the folder to share may be different if you
did not install to the default location.(see Sharing the GoldMine Folder on the Server).

Networked Workstation Installation Checklist
Uninstall linked and integrated programs: (Upgrading customers only).

Exit all running system programs and stop services: Includes third-party utilities that integrate with GoldMine, other
GoldMine add-on products (such as GoldSync), the Microsoft Office Shortcut bar. Stop all services that integrate with
GoldMine if applicable.

Create a mapped drive to the shared GoldMine folder: See Sharing the GoldMine Folder on the Server.

Install GoldMine on the Client Workstation: See Installation on a Networked Workstation.
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Verify you can launch GoldMine: Ensure the workstation installation is functioning properly.

Undocked Computer Installation Checklist
Create an Undocked license: (undocked license users only) See Licensing and Registration.

Uninstall linked and integrated programs: (Upgrading customers only).

Exit all running system programs and stop services: Includes third-party utilities that integrate with GoldMine, other
GoldMine add-on products (such as GoldSync), the Microsoft Office Shortcut bar. Stop all services that integrate with
GoldMine if applicable.

Disconnect the laptop from the network: Disconnect to ensure GoldMine configures the laptop to connect only with
the database on the local computer and not with the network.

Install GoldMine to the undocked computer: See Installation on an Undocked Computer.

License GoldMine: Use the appropriate U-license information. See Licensing and Registration.

Verify you can launch GoldMine: Ensure the undocked installation is functioning properly.

Installation on a Server
A server installation requires a GoldMine install to a local path on the server. The database and the data folder are
shared with networked clients. Workstation-based users can connect to the server data from their local computers
after Installation on a Networked Workstation.

IMPORTANT: If you are installing a new version of GoldMine after uninstalling a previous version, you
might have entries left in the Windows Registry which will cause GoldMine to assume you are upgrading.
These entries must be removed to allow you to install GoldMine. Consult with your System Administrator
before you attempt to remove any entries from your Windows Registry.

NOTE: Windows Server 2008,Windows Server 2012,Windows 7,Windows 8/8.1 andWindows 10,
have a split path installation. The gm.ini file installs into the \ProgramData\GoldMine, which

needs to be shared because this folder contains gm.ini to which realini setting from workstation

gm.ini should point. (realini=path to shared gm.ini)

To Install GoldMine on a Server
The following steps are for a New Installation. If upgrading, use the steps inUpgrading GoldMine.

NOTE: 110MB of disk space is required for installation (plus 45MB more if adding GoldMine Plus!).

1. Log directly into the server as a local administrator.
2. Download the most current version of GoldMine from the Documentation and Downloads section of our Self-

Service portal. Seewww.GoldMine.com/GoldMine-support/ to access Self-Service. Run the GoldMine
Premium installer (gmsetup-version.exe).

http://www.goldmine.com/GoldMine-support/
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The welcome to the GoldMine InstallationWizard dialog appears.

3. ClickNext to open the Readme dialog.

NOTE: The README file contains the most recent information about this version of GoldMine. A
copy of the README.htm can be found in the GoldMine ProgramData folder after the installation
has completed. A copy of the Release Notes.rtf can be accessed from the GoldMine Help menu
or found in the GoldMine Program Files folder after the installation has completed.
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Close the dialog after reviewing the information to proceed with the installation.

4. The License Agreement dialog appears.

Review the licensing information carefully; if you agree to the terms, select I accept the terms in the license
agreement.

NOTE: If you do not agree to the terms of the license agreement, select I do not accept the terms
in the license agreement. Click Cancel to terminate the installation.

5. Accepting the terms of the agreement activates the subsequent check boxes. Youmust select both check boxes
to continue with the installation.

NOTE: Select I am an authorized agent and/or representative of the customer/end-user and I
have read the terms and conditions stated above to continue.
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6. If all system requirements have beenmet, clickNext.

7. The New or Existing Database dialog appears.
8. Choose the Install GoldMine to connect to a new database option.



Page 19 of 67

9. ClickNext to open the Custom Setup dialog .

The Install to: path defaults to C:\Program Files\GoldMine\ (for 32-bit OS) or to C:\Program Files 
(x86)\GoldMine (for 64-bit OS). It is highly recommended that you install to the default path.

IMPORTANT: GoldMinemust be installed to a local drive and folder; do not select a mapped drive
during installation. After the install is complete, the data folder is shared for network client access.

The GoldMine Premium Edition and GoldMine Plus! options are selected for installation by default.

NOTE: If you select the Microsoft Excel option and plan on having others use it, besides the
current installing user, youmust make changesmanually to the registry key. SeeModifying the
Registration Key.

There are three options under the GoldMine Plus! option:

○ For Microsoft Word
○ For Microsoft Excel
○ For Microsoft Outlook
If you do not want to install the GoldMine Plus! components, click the GoldMine Plus! icon, select This feature is
not available from the drop-downmenu, and then clickNext. You can also choose to exclude individual
GoldMine Plus! components during the installation.

These components can be installed at a later date by going toWindows Control Panel > Programs and
Features > GoldMine > Change andmodifying the existing installation.

10. To install the selected GoldMine features.

NOTE: A compatible version of Microsoft Office must be installed prior to installing GoldMine Plus!
components.
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11. ClickNext to open the Demo Data Options dialog .

12. To add the demonstration data to the database, check the Install Demo Data with GoldMine box.

NOTE: When upgrading, this dialog does not appear

13. Select the correct local version of English for your installation.
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14. ClickNext to open theMS SQL Administrator Login dialog.

○ MS SQL Server Name:Type or select the name of the computer on your network where SQL Server is
installed. When using named instances (such as default onMS SQL Express Editions installations) type the
name of the MS SQL Server instance; example: MACHINENAME\SQLEXPRESS.

○ MS SQL Database Name:GoldMine creates and installs the demo data in a SQL database called GoldMine. If
you want your database to have a different name, type it in the text box.

○ MS SQL Administrative Username:The default login is sa. If your SQL Server user name is different, your SQL
administrator must provide the information.

○ MS SQL Administrative Password:Enter the SQL Server administrator password.
○ MS SQL Database Owner:The default name of the SQL Server database owner is dbo. There is no need to

change this value.
○ Create Unicode Database: Check this option to create a Unicode Database. Checking this option will greatly

increase the size of your database.

NOTE: If you clickNext without typing a user name and password, the Insufficient Input dialog
appears. Click Back. If you enter incorrect information and clickNext, theMS SQL Login Failed
dialog appears. Review the troubleshooting tips, then click Back.

15. ClickNext to continue and to open the Ready to Install the Program dialog.
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IMPORTANT: Microsoft SQL 2008/2012/2014 Express is the minimum requirement for the GoldMine
database. Compatible SQL Express editions have a maximum database size of 10 GB.

If you plan on installing GoldMine on other computers, check the Create a configuration file for unattended
installation box to create a configuration file with these settings.

If you choose not to use this option, you canmanually create the unattended installation script (see Creating an
Unattended Installation Script).

16. If you selected any of the GoldMine Plus! options, a Question box appears.

17. Click Yes to install the Microsoft Office add-ins, or clickNo to skip installation of these add-ins and only install
GoldMine.

18. The Installing GoldMine dialog opens.
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19. When the Installation Completed dialog appears, click Finish.

TheWelcome to GoldMine dialog opens to begin the licensing process. See Licensing and Registration.

Unattended Installation
Another installation option is the Unattended Installation (also known as Silent Install). This option allows installation
without user interaction. Installing GoldMine using the unattended installationmode recreates the same steps as a
workstation install, using user responses stored in a configuration file.

For example, you perform a full GoldMine installation on a clean computer (a computer with no previously installed
versions of GoldMine) using the connect to existing database option. Then you run the GoldMine installer in
unattendedmode on the other computers. GoldMine will be installed into the same directory with connect to
existing database option.

TIP: A GoldMine administrator can create unattended installation scripts for various installation
scenarios.

The Unattended Installer uses a special configuration file named gm_si.ini. For detailed instructions on how to
create this file, see To Create Configuration File for Unattended Installation.

NOTE: The generated gm_si.ini is meant to be deployed to a machine with a similar condition. If

you create a gm_si.ini file from a machine that has been upgraded, the same gm_si.ini can
not be deployed as a new installation in another machine.
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To Create Configuration File for Unattended Installation
1. Run GoldMine installer as usual.

For more information on installing, see Installation on a Server.
2. Proceed to the Ready to Install the Program dialog.
3. Select the Create a configuration file for unattended installation checkbox.
4. In a default install the file will be created in the:

C:\ProgramData\GoldMine\Setup\GoldMine folder, and be named gm_si.ini

5. Click Install.

The configuration file and bat file (gmsetup_si.bat) will be created.

TIP: You can also create an unattended installation script after installation. For more information,
see Creating an Unattended Installation Script.

NOTE: If the installer in unattendedmode cannot repeat exactly the user mode steps, then the
installer will switch to an interactive mode and the user canmanually continue with the
installation.

To Manually Run the Unattended Installation
Manually run the unattended install using gmsetup_si.bat file.

NOTE: GM installer files gmsetup.exe, gm_si.ini, and gmsetup_si.bat should be placed into
the same directory.

In some cases the unattended installer cannot repeat the exact steps as a normal install. For example, the
unattended installer cannot perform a full installation (without previously installed GoldMine) on the computer with
GoldMine already installed with the same version because the installer is running in maintenance mode.

Automatic Upgrade
Use the following procedure to upgrade networked workstations.

To Upgrade Unattended Installation
1. Create the configuration file.

For instructions, see To Create Configuration File for Unattended Installation.
2. Select GoldMine > Tools > Configure > System Settings > Auto-Upgrade.
3. Set the paths and filenames of the GoldMine installer and configuration file created in step 1.

NOTE: This must be a UNC path to a sharable directory.

After completing this procedure, any local installs of GoldMine will automatically prompt users to upgrade GoldMine
whenever the local GoldMine version is less then the server GoldMine version.
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Installation on a Networked Workstation
A NetworkedWorkstation setup installs GoldMine on the workstation and enables a workstation user to connect to
the Server copy of the GoldMine database from their individual computer.

Share the GoldMine data folder on the server. If you plan to access the data folder by a mapped drive, thenmap the
same drive on each workstation to the shared GoldMine folder on the server. It is recommended that a UNC path be
used instead of a mapped drive. This is required for use of GoldMine Connect..

Sharing the GoldMine Folder on the Server
To run the shared folder installation, after installing the Server setup, share the GoldMine data directory (default:
C:\ProgramData\GoldMine\)so the NetworkedWorkstation functions properly. All GoldMine users must have
rights to read, write, modify, and delete files for GoldMine to function on the NetworkedWorkstation.

NOTE: Sharing can expose other applications. Do Not install GoldMine as a root folder of the drive,
rather, install to C:\Program Files\GoldMine (32-bit OS) or C:\Program Files (x86)

\GoldMine (64-bit OS) on the Server. We highly recommend installing GoldMine to the default
paths.

Your procedure might vary depending on the operating system where the Server database is located. Refer to the
documentation that came with your operating system for detailed instructions.

To Share the GoldMine Folder on the Server
To share the GoldMine folder youmust perform two steps: share the folder and configure the permissions. Follow
the procedures listed below to share the GoldMine folder.

Share the GoldMine Folder

1. Open the Windows Administrative Tools > Computer Management.
2. In the console tree, expand System Tools > Shared Folders and right-click on Shares.
3. On the Actionmenu select New Share.
4. Follow the steps in the Create a Shared Folder Wizard, and then click Finish.

NOTE: If you are planning to use a workstation where the Connect to Existing Database Install will
be used, share the \ProgramData\GoldMine data folder.

Configure The Share Permissions

1. Log on to the computer as Administrator or as a member of the Administrators group.
2. OpenWindows Administrative Tools > Computer Management.
3. In the console tree, expand System Tools > Shared Folders and click on Shares.
4. In the details pane, right click the shared folder and then click Properties.
5. On the Share Permissions tab, select the Group or User Name.
6. To set individual permissions for the Group or User Name, select either Allow or Deny. Click Apply, thenOK.

NOTE: Full Control of the \ProgramData\GoldMine folder is needed for all GoldMine users.
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Configure the GoldMine Server to Emulate a Network Workstation

If mapped drives will be used to access GoldMine from the networked workstations, the same drive should be
mapped on the server.

1. Start Windows Explorer and select Tools > Map Network Drive.
2. From the Drive list box, select the designated drive letter for mapping to the GoldMine folder on the server.
3. From the Folder list box, browse to the shared GoldMine folder
4. Select the Reconnect at Logon check box.
5. ClickOK.
6. Click Finish.

Mapping a Drive on the Networked Workstations
We recommend that GoldMine be accessed by UNC path. This is necessary if you plan to use GoldMine Connect. If
GoldMine will be accessed by a mapped drive, all networked workstations accessing the shared GoldMine folder
must be mapped to the same network drive letter (for example, G:\) to facilitate GoldMine administration and
operations related to linked documents and synchronization.

Mapping on the Server

The SysDir entry in \ProgramData\GoldMine\gm.ini must be changed so that it points to the mapped folder
containing the LicenseGM94.bin file.

For example, if GoldMine was installed to C: and \ProgramData\GoldMine wasmapped to G:, the SysDir entry
in C:\ ProgramData\GoldMine\gm.ini would be changed to: SysDir=g:\

The RealIni entry Program Files\GoldMine\gm.ini (for 32-bit OS) or Program Files (x86)

\GoldMine\gm.ini (for 64-bit OS) must be changed so that it points to the gm.ini file in the mapped
ProgramData\GoldMine folder.

For example, if GoldMine was installed to C: and \ProgramData\GoldMine wasmapped to G:, the RealIni entry
C:\Program Files\GoldMine\gm.ini (32-bit OS) or Program Files (x86)\GoldMine\gm.ini (64-bit OS)
would be changed to: RealIni=g:\gm.ini

On each workstation where the Connect to Existing Database Install option will be used, the following shared folder
should be mapped:

\ProgramData\Goldmine folder.

To Map a Drive in Windows 7, Windows 8 / 8.1, or Windows 10
1. Open the Windows Start menu and select All Programs > Accessories
2. Right click on Command Prompt shortcut and choose Run as Administrator.
3. Type “net use <drive:> <UNC path to the shared drive> /p:y”

For example: net use g: \\server name\goldmine /p:y

4. Click the Windows Start button, then select Computer and select Map network drive
5. From the Drive list box, select the designated drive letter for mapping to the GoldMine folder on the server.
6. From the Folder list box, browse to the shared GoldMine folder
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7. Select the Reconnect at Logon check box.
8. ClickOK and then click Finish.
9. Repeat this procedure on each client workstation computer.

After the GoldMine installation is complete, restart GoldMine. This will facilitate the use of GoldMine with the
GoldMine Plus add-ins.

Set the GoldMine System Directory on the Server
The GoldMine System Directory points to the location of the LicenseGM94.bin. This entry must be set
appropriately, to allow access by networked clients and by some integrations. Set the System Directory using the
following procedure.

1. Log in to GoldMine as a user withMaster rights.
2. Select Tools > Options to open the USER's Option dialog.
3. Select the Login tab. (This tab is not available for a user withoutmaster rights.)
4. Enter or browse to the location of the GoldMine Data folder using either a UNC path (recommended) or a

mapped drive.

NOTE: This is a GLOBAL setting for all GoldMine users.

5. ClickOK to save and exit Options.

Installing on a Networked Workstation
The Workstation step installs GoldMine on the workstation and enables the workstation user to connect to a shared
copy of the GoldMine database.

1. At the workstation, run the gmsetup.exe file.

NOTE: This file must be the same as the one used for the version of GoldMine installed on the
server.

Double-click to run the executable. TheWelcome to the GoldMine Installation Wizard dialog appears.
2. ClickNext to open the ReadMe dialog. After reviewing the most recent information about this version of

GoldMine, close the ReadMe to proceed with installation.
3. ClickNext to open the License Agreement dialog.
4. Review the licensing information carefully; if you agree to the terms, select I accept the terms in the license

agreement.

NOTE: If you do not agree to the terms of the license agreement, select I do not accept the terms
in the license agreement. Click Cancel to terminate the installation.

5. Accepting the terms of the agreement activates the subsequent check boxes. Youmust select both check boxes
to continue with the installation.

NOTE: Select I am an authorized agent and/or representative of the customer/end-user and I
have read the terms and conditions stated above to continue.

6. ClickNext. The System Requirements page appears. Verify all system requirements have beenmet.
7. ClickNext to open the New or Existing Database dialog.
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NOTE: We recommend a UNC path to the shared ProgramData\GoldMine folder on the server
be entered.
Example: \\servername\GoldMine

8. Choose the Install GoldMine to connect to an existing database option, and then click the Browse button to
navigate to the to GoldMine shared path on the application server.

9. ClickNext to open the Custom Setup dialog.
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The default installation location is C:\Program Files\GoldMine (32-bit OS) or C:Program Files (x86)

\GoldMine (64-bit OS).

NOTE: If you select the Microsoft Excel option and plan on having others use it, besides the
current installing user, youmust make changesmanually to the registry key. SeeModifying the
Registration Key.

IMPORTANT: Choosing a location outside of the \Program Files (32-bit OS) or \Program Files

(x86) (64-bit OS) directory can cause a loss of certain functionality, such asmacro recording. This is due

to security requirements which connect certain privileged functions with the locations from which their
associated executables are launched.

10. ClickOK to open the Ready to Install dialog.
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NOTE: The Create configuration file for unattended installation option allows you to create the
gm_si.ini file. This file can be used to establish settings for future Workstation installation based
on the settings of this Workstation.

A GoldMine administrator can also create unattended installation scripts for various installation scenarios (see
To Create an Unattended Installation Script).

11. Click Install.
12. If you selected any of the GoldMine Plus! options, a Question box appears.

13. Click Yes to install the Microsoft Office add-ins, or clickNo to skip installation of these add-ins and only install
GoldMine.

14. When finished, the Installation Completed dialog appears.
15. Repeat this process for each workstation accessing GoldMine.
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Installation on an Undocked Computer
An Undocked setup is the same as a full setup, with the only difference being the license number. For detailed
installation instruction, see Installation on a Server.

If the undocked computer you are upgrading or installing works remotely, see Upgrading GoldMine.

Read the following points before running an undocked computer installation:

■ If installing an Undocked version of GoldMine while it is in your office, disconnect the laptop from the network so
you install a completely independent copy on the computer.

■ An Undocked installation is performed for users that frequently work remotely and are not connected to the
office network via a faster connection. The user works on a local database on their computer. Data is
exchanged between the user’s local database and the office database during synchronization. For more
information, see the online help for instructions on setting up GoldSync.

■ Instead of using the gmsetup.exe to install GoldMine on an undocked workstation, you can run the installation
by using an installation file for One-Button Synchronization. For further information, refer to the
“Synchronization” chapter of the GoldMine Administrator Guide (or the “Synchronization” topic in the online
help).

Creating an Unattended Installation Script
During installation, you have the option to Create a configuration file for unattended installation (see Installation on
a Server). If you are planning on installing or upgrading GoldMine on other computers, you can use this file or create
a new one

By creating a customized installation script, you can choose precisely the script parameter information you want to
proliferate to the other computers on your network. This script can then be used for your unattended installations.

Use Case Scenarios

■ New Installation
Create installation file that enables GoldMine to be installed and licensed on an undockedmachine in an
unattendedmode. Repeat this process for 20 undockedmachines

■ New Installation Connecting to Existing Database
Create installation file that enables GoldMine to be installed on a networkedmachine in an unattendedmode
that connects to an existing database. The process is similar to a New Installation above.

■ Upgrade Installation
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Upgrade an undockedmachine with a new license. This process should not require that the administrator have
physical access to the machine. Repeat this process for any additional undockedmachines.

To Create an Unattended Installation Script

1. Start GoldMine and login as an administrator.
2. Open the Toolsmenu and select Configure > System Settings.
3. Click the Script for unattended installation tab.
4. Open the drop-downmenu and select the installation type:

○ New GM installation with connect to existing database
○ New GM installation with new database
○ Upgrade from previous version using Microsoft SQL Server database

5. Select or modify any Value for each Property as needed.
6. Click the Create button to generate the script. The location where the script is saved will be displayed.
7. ClickOK to close the System Settings dialog.

Following is an example of the two files created:

○ NewGm-NewDb-X-000390-EVALNR-00000-00000-00000.ini

○ NewGm-NewDb-X-000390-EVALNR-00000-00000-00000.bat
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To Run an Unattended Installation Script
1. Create an Unattended Installation Script (see To Create an Unattended Installation Script).

2. Place a copy of the .INI and .BAT file in the same location as the GoldMine installation file.

For example, the following files would need to be in the same directory to run the script:

○ <scriptname>.ini

○ <scriptname>.bat

○ gmsetup.exe

3. Run the <scriptname>.bat file to start the installation.

Modifying the Registration Key
If you install GoldMine Plus!, it is only active for the current user. If you want other users of the same system to have
access toMicrosoft integration features, youmust make changesmanually to the system registry for each additional
user. This change is only required for Excel. Tomake these changes, follow the steps listed below.

To Modify the System Registry for Additional GoldMine Plus! Users
WARNING: You should create a backup of your Windows Registry before making any changes.

1. Login as different user account.
2. Open the WindowsStartmenu and select Run.
3. Type regedit in the textbox and clickOK.
4. Expand the tree to:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\<YOUR VERSION>\Excel

The <YOUR VERSION> Office folders are as follows:

○ For Office 2007 = 12.0
○ For Office 2010 > 14.0
○ For Office 2013 > 15.0
○ For Office 2016 > 16.0

5. Expand the Excel folder.
6. Right-click onOptions and select New > String Value from the context menu
7. Name the new string OPEN.
8. Right-click the OPEN string and select Modify.
9. Enter the following string in the Value data textbox:

/A “GMPlusOffice2007.UserDefinedFunctions”

10. ClickOK to save the changes.



Licensing and Registration

Overview
GoldMine has a fully scalable licensing structure tomeet the needs of individuals and organizations. As your
businessmatures and GoldMine expands, your organization can change the licensing configurations.

General Licensing Information
The single, distributedMaster License serves as the authenticationmechanism for secure synchronization across
the entire organization, and the License Manager keeps track of your licensing configurations.

Most organizations generally buy one license—aMaster License with x number of seats. These seats can then be
parsed to users in various combinations of sub-licenses. For example, an organization can create Site sub-licenses
for their remote office(s) and Undocked sub-licenses for individual remote users. One seat should always be set
aside for administrators.

License Types
■ Master License: This is the primary license. It determines what database types are supported by the master site

as well as its synchronization capabilities. It is a precursor to executing any sub-licenses which stem from it.

NOTE: GoldMine Web, GoldSync and Outlook Integration licenses are included in E licenses.

TIP: For information about licensing serial number schema, see License Serial Number.

■ Sub-licenses: To issue, install GoldMine with a Master License on your organization’s primary network. This
ensures all sub-licensesmaintain security and are authenticated properly during synchronization.

NOTE: The Undocked license (a special sub-license) is for remote users and can only be licensed
for a single user. It can be sub-licensed from the main GoldMine system or from a Site sub-
license.

■ Increases: Licenses increases are facilitated by obtaining a new E license.
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Master License

E Supports SQL databases and includes GoldSync

M GoldMine Mobile License Support for GoldMine Mobile users.

Sub-licenses

U Undocked License Single sub-license for a remote GoldMine user

S Site License Multiple-user sub-license for a remote office

Y GoldSync License GoldSync sub-license for a remote office

License Serial Number
The schema for the serial number has changed. Because of the new licensing schema, the GoldMine installer will not
upgrade your license. This example illustrates what a GoldMine license serial number looks like:

■ License type: Alpha-prefix denotes the type of Master license.
■ Number of users: First 4 numbers indicate the license count or seats available in the license. The license count

determines the number of users who can log on to GoldMine at one time but does not limit the total number of
named users.

■ Version: A 2-digit version number.
■ HDA number: A unique 6-digit customer account number, also referred to as the Help Desk Authorization (HDA)

Account.
■ Serial number: 15-character (alphanumeric) serial number uniquely identifying the license for an organization. It

is used for registration and support and identifies all sub-licenses as part of the same organization. Collected in
3 groups of 5 characters during licensing.

■ Key code: 15-character (alphanumeric) key code is a computer-generated check used by GoldMine to verify the
license’s validity. Collected in 3 groups of 5 characters during licensing.

NOTE: The license is required for the product to run. Keep the license number and key code in a
safe place in the event it becomes necessary to reinstall the software.
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License Manager
Initial licensing information is collected during installation. Subsequent changes and relatedmanagement functions
are handled through the License Manager.

To open the License Manager, launch GoldMine, open the Toolsmenu and select Configure > License Manager.

The central text box lists all installed licenses and any sub-licenses created from this loc ation. Status is displayed
along the right side. Buttons along the bottom allow you to add a New License, add a New Site, add anUndocked
User, Remove License, or View License.

The database support of the Master License is inherited by the site sub-licenses distributed throughout the
organization. GoldSync Synchronization capabilities can be distributed separately to sub-licenses.

NOTE: Licensing information is stored in the license file, LicenseGM94.bin, created at the time
you register. This file must exist only in the GoldMine main data directory of each GoldMine
installation.

TIP: Additional License Manager information is provided in the Online Help.

LicenseGM.bin File Locations

The LicenseGM94.bin file is located in \ProgramData\GoldMine for all installationsmade to the default
(recommended) location. Networked workstations will access the LicenseGM94.bin file at the GoldMine server.
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Licensing with a Master License
A GoldMine Premium Edition Master License begins with the alpha-prefix E.

For Example: E-002594-123456-...

The E-license is usually a multi-user license for a Server installation of GoldMine, but can be a single-user license for a
UndockedWorkstation computer.

An E-license includes a GoldSync license for each purchased GoldMine seat.

Remote site sub-licenses (S- and Y-licenses) and Undocked sub-licenses (U-licenses) are created from the E-license.

Type the E-license number and key code you received when you purchased the software.

NOTE: If you type an E-license serial number into the text boxes, the GoldSync text box area
remains unavailable because GoldSync is included.

Licensing Following Installation
1. After the installation completes, click Finish. The licensing wizard launches.

NOTE: If you do not complete the license and registration information after installation, the
licensing wizard launches prior to first use of GoldMine.

The Enter GoldMine Serial Number dialog appears.

2. Type your GoldMine serial number and key code.
3. ClickNext to open the Enter License Information dialog.
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NOTE: The following fields are used in GoldMine when using address information for the
VCard (.vcf file):

- Mailing Address = Address1 (steet address) + Address2 (suite/room number)
- Home Street Address = Address1

This information can also be accessed from the Registration tab in the GoldMine License
Manager (Tools > Configure > License Manager). For more information, refer to the GoldMine
Online Help.

4. Enter your contact information in the designated text boxes to continue. Organization, Contact Name, E-
mail address, Phone,Address1, and City fields are required.
Click the checkbox if you want to receive future product information.

5. ClickNext to open the Import Windows User Accounts dialog.
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6. Select each user account you want to import into GoldMine. If appropriate, type an optional password for
imported names.

NOTE: Imported users do not have “master” rights.

7. ClickNext to open the Enter Your Username dialog.
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8. Type a user name (eight characters or fewer). The password is optional for Premium Edition but is required for
users accessing GoldMine through GoldMine Web. GoldMine requests these at log in. This user hasMaster
Rights in GoldMine.

9. Click Finish to open the GoldMine Logon dialog.

10. Type the user name and password and clickOK to launch GoldMine.
11. After logging in, the Universal Search dialog opens.

IMPORTANT: Microsoft SQL Server Full Text Searchmust be installed and configured prior installing
GoldMine Universal Search.

Click Yes to proceed with Universal Search or No to ignore the option.
If you clickNo, Universal Search can still be installed at a later time. For more information, see “About Universal
Search” in the GoldMine User Guide or Online Help.

Creating Sub-licenses
After GoldMine is installed and licensed, you can parse seats to your end users with sub-licenses using the License
Manager. Youmust have a Master License to create sub-licenses.
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IMPORTANT: Plan before creating sub-licenses, keeping in mind each sub-license transfers seat
availability which affects how many users can log in on the network system. For example, on the Licenses
tab of the License Manager, if the Total users/dist: shows a total number of seats and the total number of
sub-licenses as “50\20,” only 30 seats are available to users. At a minimum, one seat should always be set
aside for administrators only.

Creating Sub-licenses for Remote Offices
From a Master License, you can create sub-licenses for remote offices. Remote office sub-licenses can be a Site
License (S-license) and/or a GoldSync License (Y-license).

Each “S” sub-license transfers seat availability from non-remote users. A minimum of one seat must remain available
to non-remote users. For example, youmust have at least 5 seats to make GoldMine available to 4 remote offices.
Headquarters retains the fifth seat.

NOTE: When creating any sub-license, note the entire license number created by GoldMine. The
sub-license includes the key code and additional information needed when licensing the remote
computer.

To Create a Sub-license for a Remote Office

1. From the GoldMinemenu, select Tools > Configure > License Manager. The License Manager appears.
2. Click the Licenses tab.
3. ClickNew Site to open the Create a Site Sub-License dialog.

4. In the Distributed License Type area, select the site license you want to create; GoldMine Site License (S-
License)for the number of seats the site needs or GoldSync Site License (Y-License) for the number of users who
are synchronizing, including at least one for the site.
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TIP: Write the sub-license number down or copy it toWindows Notepad. The sub-license number is
needed for each remote computer installation. Send the remote site license number to the
remote user who can type the license number during the GoldMine installation.

5. In the Site Sub-License area, type the site name and number of users.
6. Click Create Site Sub-License to open the The Sub-License for Remote Site dialog.
7. Review the information about the sub-license and click I Agree. The sub-license number for the site appears in

the Sub-license for Remote Site [Name of Site] dialog.
8. If you created a Site license, repeat the above process to create the necessary GoldSync license and select

GoldSync Site License.

NOTE: GoldMine adds the sub-license to the list of licences on the Licenses tab of the License
Manager.

Creating Sub-licenses for Undocked Users
GoldMine has a sub-license for an individual user called anUndocked License (U-License). This license type is created
for users who work primarily with GoldMine at a remote location on a laptop, notebook, or home office computer
but whomay also need to log on to the network occasionally. Consider:

■ Creating an undocked user decreases the available users of the network site (Master License or Site License) by
one; however, when an undocked user logs on to the site from which they were sub-licensed, they do not take
up an additional seat.

■ Every user supported by the GoldMine license can have an Undocked license to work on a remote computer. For
example, on a 5-user GoldMine system, 5 Undocked licenses can be created. This is in contrast to creating an
“S” sub-license which requires one seat to remain available from the Master License.

■ All undocked users, as well as the total number of users that make up the difference in the total number allowed
by the Master License can log on to GoldMine. For example, on a 5-user GoldMine system with 3 undocked
users, 3 undocked users plus 2 other users can log on to GoldMine.

WARNING: If you undock all users, only those users will be able to log in. If you have not assigned
master rights to any of those undocked users, GoldMine administration cannot take place.

■ When used in combination with GoldSync, administrators can synchronize security settings to undocked users
including new passwords, menu items, and preferences in addition to data.

■ To work on an undocked basis, users must have an Undocked license on their laptop. Create an Undocked license
from the Master License or a Site license.

To Create a Sub-license for an Undocked User

1. From the GoldMinemainmenu, select Tools > Configure > License Manager. The License Manager appears.
2. Click the Licenses tab andUndock Users to open the Create Undocked User Licenses dialog.
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3. Select the check box next to the user you want to create a sub-license for, and click Create Undocked License to
open the Sub-Licenses dialog.

4. Review the information and click I Agree. The sub-license number for a remote user or an undocked user
appears in the Sub-license for Remote Site [Name of Site] dialog.

TIP: Write the sub-license number down or copy it toWindows Notepad. The sub-license number is
needed for each remote computer installation. Send the remote site license number to the
remote user who can type the license number during the GoldMine installation.

Licensing with Sub-licenses

Site License
A Site License is a multiple-user sub-license for a remote office and is designated with the alpha-prefix “S.” You
should have an S-license for each user at the remote site.

A GoldSync License (Y-license) is required only if you are using an S-license and want to synchronize using
GoldSync. You should have one Y-license to synchronize with the Master License and additional Y-licenses for
Undocked users synchronizing with your site.

NOTE: Y licenses are not entered in the Enter GoldMine Serial Number dialog. Only S licenses
are entered during registration (the GoldSync Section remains disabled). Clicking Next displays an
ALERT: Suggested Action(s)! if you try to enter Y licenses in the Enter GoldMine Serial Number
dialog .

If this installation of GoldMine includes its own GoldSync sites, youmay enter the applicable Y-type sub-licenses to
properly configure synchronization for this system.

1. To configure applicable sub-license sites, select Tools > Configure > License Manager to enter your Y-type
license.

2. In the GoldMine Serial Number text boxes, type the S-license, Key Code, and Site Code you created in the
License Manager of the main GoldMine system.
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3. In the GoldSync Serial Number text boxes, type the Y-license, Key Code, and Site Code you created in the License
Manager.

Undocked License
Undocked licenses are sub-licenses created from a Master License or a Site license and are designated by the letter
“U.” This license type is created for users who work with GoldMine at another location, on a laptop, or on a
workstation disconnected from the server copy of GoldMine.

Type the U-license, Key Code, and Site Code created in the License Manager.

Evaluation License
The Evaluation license allows you to evaluate GoldMine Premium Edition for 30 days. During or after this time you
can purchase a production GoldMine license and apply it to your database.

You will receive a warning of the approaching expiration of the evaluation license. If you do not apply a production
license within 30 days, product performance will degrade tomake GoldMine unusable for practical use, but will
permit an administrator to access the application to add a license or re-evaluate the user interface.



Upgrading GoldMine

The upgrade process is intended to be used with GoldMine 9.0.0 or higher. There is no need to uninstall the
existing version, or remove folders and databases before proceeding. If you are upgrading a prior version, youmust
upgrade to 9.0.0 before upgrading to the latest version. Contact Customer Care at 800.776.7889 for information
about upgrading from versions prior to 9.0.0.

NOTE: Back up your existing GoldMine database and system before beginning the upgrade.

■ A database conversionmight be required when upgrading from earlier versions of GoldMine. This conversion
occurs automatically when GoldMine is installed into the path of the existing gmw.exe.

IMPORTANT: If you are upgrading a large Microsoft SQL Server database (5GB of data or more),
note that certain computers (limited computing power) require manual steps to upgrade the database
successfully.

■ Undocked users must be on the same version and build of GoldMine as the site with which they sync. If you are
upgrading the server but are not upgrading UndockedWorkstations until a later time, disable their sync sites
in the GoldSync Administration Center on the server. Reactivate their site when the undocked computer is
upgraded and is running the same version and build of GoldMine as the server.

■ Ensure you have adequate disk space available prior to installation.

NOTE: If your company policy requires that you uninstall the previous version of GoldMine to run
a “clean” installation, youmight have entries left in the Windows Registry which will cause
GoldMine to assume you are upgrading. These entries must be removed to allow you to install
GoldMine. Consult with your System Administrator before you attempt to remove any entries
from your Windows Registry.

Upgrading Existing GoldMine
The following procedure describes an upgrade process for customers who have the following:

■ GoldMine 9.0.0 or newer
■ SQL Server/SQL Server Express GoldMine database

If you are upgrading from a previous version of GoldMine and have a large Microsoft SQL Server database (5GB of
data or more), refer toMigrating Large Databases.

IMPORTANT: Before upgrading GoldMine, we recommend backing up your existing database.

To Upgrade GoldMine
1. TheWelcome to the GoldMine InstallationWizard dialog opens.
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2. ClickNext to open the Readme dialog.

Close this dialog box after reviewing the most recent information about this version of GoldMine to proceed
with the installation.

3. The License Agreement dialog opens.
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4. Review the licensing information carefully; if you agree to the terms, select I accept the terms in the license
agreement.

NOTE: If you do not agree to the terms of the license agreement, select I do not accept the
terms in the license agreement. Click Cancel to terminate the installation.

5. Accepting the terms of the agreement activates the subsequent check boxes. Youmust select both check boxes
to continue with the installation.

NOTE: Select I am an authorized agent and/or representative of the customer/end-user and I
have read the terms and conditions stated above to continue.

6. ClickNext. The System Requirements page appears. Verify that all system requirements have beenmet.
7. ClickNext to open the Custom Setup dialog.
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The path of the existing installation is noted and cannot be changed. To install to a different path, youmust first
upgrade the existing installation to the desired version. Youmay then uninstall and reinstall to the desired
location.
The GoldMine Premium Edition and GoldMine Plus! options are selected for installation by default. There are
three options under the GoldMine Plus! option:

○ For Microsoft Word
○ For Microsoft Excel
○ For Microsoft Outlook
If you do not want to install the GoldMine Plus! components, click the GoldMine Plus! icon, select This feature
will not be available from the drop-downmenu, and then clickNext. Alternately, you can select individual
GoldMine Plus! components for exclusion during installation.
These components can be installed at a later date by going toWindows Control Panel > Programs and

Features > GoldMine > Change andmodifying the existing installation.

8. To install the selected GoldMine features, clickNext.

NOTE: A compatible version of Microsoft Office must be installed prior to installing GoldMine Plus!
components.

9. ClickNext to open theMS SQL Administrator Login dialog.
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The Server Name, Database Name, and Database Owner fields are retained from the previous installation and
not required during the upgrade. The only fields required in this dialog are:

○ MS SQL Administrative Username:The default login is sa. If your SQL Server user name is different, your SQL
administrator must provide the information.

○ MS SQL Administrative Password:Enter the SQL Server administrator password.

NOTE: If you clickNextwithout typing a user name and password, the Insufficient Input dialog box
opens. Click Back. If you type incorrect information and clickNext, theMS SQL Login Failed dialog
opens. Review the troubleshooting tips, then click Back.

10. ClickNext to continue.

IMPORTANT: Compatible SQL Express Editions have a maximum database sixe of 10 GB.

11. The Ready to Install the Program dialog opens.
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If you will be installing GoldMine on other computers sharing these same configuration settings, you can check
the Create a configuration file for unattended installation box to create a configuration file with these settings.
A GoldMine administrator can also create unattended installation scripts for various installation scenarios (see
To Create an Unattended Installation Script).

12. Click the Install button.
13. If you selected any of the GoldMine Plus! options, a Question box may appear if required components are

missing.

14. If prompted, select Yes to install the Microsoft Office add-ins, or clickNo to skip installation of these add-ins and
only install GoldMine.

15. The Installing GoldMine dialog opens.
16. When finished, the Installation Completed dialog opens. Click Finish to start GoldMine.
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17. If you are upgrading from version 9.0.x - version 2014.1.x, the GoldMine License Upgrade window will appear.
Youmust enter a new license number before you can launch GoldMine. Contact GoldMine Customer Care if you
do not have the new license number.

18. Enter your login information. GoldMine updates your database and starts the program.

NOTE: If you are upgrading from a previous version of GoldMine that supported Dashboards, a
message box displays asking if you want to overwrite the existing predefined Dashboards. Click Yes
to overwrite or No to keep your existing predefined Dashboards.
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Upgrading Remote Systems
This type of upgrade is for computers working disconnected from a Server but synchronizing with the main Server to
update GoldMine information: a remote Site or an UndockedWorkstation computer.

■ If you are upgrading a Site, the Master installation provides the site administrator with the gmsetup.exe. For
more information, see Installation on a Server.

■ If updating an undocked computer, the Master installation provides the undocked computer user with the
gmsetup.exe. For more information, see Installation on an Undocked Computer.

■ If you are upgrading the server but are not upgrading a remote system until a later date, disable the site in the
GoldSync Administration Center until it is running the same version of GoldMine as the server.

To Upgrade a Remote System
1. Upgrade the Master GoldMine site.

2. Upgrade remote computers by sending them a gmsetup.exe installation file using one of these methods:
○ CD-ROM
○ FTP site
○ E-mail
○ Accessible network drive

NOTE: Database upgrade and universal search installation are automatic when the user selects the
Yes option. If the user selects not to install Universal Search, it can be installed later by running
GoldMine with a special parameter: GMW /us:install (see Installation of Universal Search).

3. Remote users must run the installation CD or the gmsetup.exe on their computer following these upgrade
instructions.

After remote users upgrade to the same version of GoldMine as the server, they can begin synchronizing again.



Configuring

After installation, system administrators must configure GoldMine tomeet the needs of the organization. Some
preliminary setup is presented in this chapter. Additional configuration steps are presented in the online Help.

Configuration Considerations
In developing a GoldMine deployment strategy, the GoldMine administrator must carefully plan how the
GoldMine database should run and determine who is going to use it.

■ Creating users, user groups, security rights, and preferences including menu rights
■ Changing field labels
■ Creating user-defined fields and tabs
■ Setting up expanded details
■ Generating andmodifying F2 Lookup lists

To Enhance GoldMine, Configure Other Areas:
■ Automated Processes
■ Reports

To Import Existing Databases Into GoldMine, Plan the Migration by
Asking Yourself:

■ Is it essential to keep all existing data?
■ How out of date is the data?
■ Are all fields in the existing database required in GoldMine?

TIP: For details on these procedures, see the Administration topics in the GoldMine online help
Table of Contents, accessed by selecting Help > Help Topics on the GoldMine menu bar.

Placing a Custom Image in the Logon Window
To display your organization’s logo or other graphic on GoldMine’s logon screen correctly, the file must be a
bitmap within a size limit of 150 x 250 pixels.

NOTE: GM.ini is a special initialization file that stores settings that apply globally to all users
running the same installation of GoldMine.
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Place the bitmap file in the root GoldMine directory. Using a text editor such asWindows Notepad, open GM.ini.
Under the [GoldMine] section, add this line:

UserLogo=<path\<filename>

For example, if you place the graphics file MyLogo.bmp in your GoldMine directory, type this statement:

UserLogo=C:\GoldMine\MyLogo.bmp

Save GM.ini, then exit the text editor. Open GoldMine to display the changed login screen.



Installing Microsoft SQL Server

The Server setup requires that you install Microsoft SQL Server before installing GoldMine. Microsoft SQL Server
2014 Express with Advanced Services is used as the example in this section. Microsoft SQL Express includes 10 GB
of storage per database. It may be appropriate to consider another Microsoft SQL Server Edition such asMicrosoft
SQL Standard for use in your environment and tomeet your needs. For information to help you determine the
appropriate edition of Microsoft SQL server and guidance for installing other supported editions or versions of
Microsoft SQL Server, please refer to documentation available from the Microsoft website..

The following instructions include installation procedures and settings pertinent to GoldMine but should not be
considered a SQL Server administrator’s guide. Only experienced SQL administrators should configure SQL Server
with anything other than the settings described in these instructions.

Installing Microsoft SQL Server 2014 Express with
Advanced Services

Supported operating systems for Microsoft SQL Server 2014 Express include Windows 10,Windows 8.1,Windows 8,
Windows 7,Windows Server 2008 R2,Windows Server 2012,Windows Server 2012 R2.

NOTE: For detailed hardware and software requirements for installing supported versions of
Microsoft SQL Server please check documentation available from the Microsoft website.

1. DownloadMicrosoft SQL Server 2014 Express from the Microsoft website. In order to use Microsoft SQL
Server Reporting Services, youmust download Express with Advanced Services. Run the downloaded .exe to
start the installation. Choose your desired directory to save the extracted files.
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The SQL Server Installation Center opens.

2. From the menu list on the left, select Installation then select New SQL Server stand-alone installation or add
features to an existing installation from the options on the right.

3. The SQL Server 2014 Setup dialog opens to the License Terms.
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Read the licensing agreement and check the I accept the license terms box to indicate agreement. Check the
box to turn on Error Reporting if desired.

4. The Global Rules dialog runs the Rule check to identify problems that might occur. Failuresmust be corrected
to proceed. Check the Microsoft website for further information about any failures.

5. If no failures occur, the Product Updates page opens. Include SQL Server product updates as desired. Click
Next to proceed.
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6. Install Setup Files runs.

7. Install Rules will run. If no failures occur the Feature Selection dialog will open.
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8. Select the Instance Features: Database Engine Services, Full-Text and Semantic Extractions for Search,
Client Tools Connectivity, Client Tools Backwards Compatiblity, andManagement Tools - Basic and
Complete

NOTE: If you plan on using Reporting Services with GoldMine, Reporting servicesmust also be
selected and installed.

Then clickNext.
9. At the Instance Configuration dialog select the Named instance option and clickNext.
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10. ClickNext at the Server Configuration dialog since no changes need to be made to the configuration.

11. ClickNext to open the Database Engine Configuration dialog.
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Select theMixedMode option, then enter and confirm the password. Youmay also specificy SQL server
administrators.

IMPORTANT: Passwords should be retained in a safe place.

12. If you selected to install Reporting Services, the Reporting Services Configuration page will open. Consult
the Microsoft website for more information regarding this.

13. ClickNext to open the Installation Progress dialog .

14. When installation is complete the Complete dialog displays advising you to restart your computer.
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15. ClickOK on the Computer restart required window.
16. Click Close on the Completewindow, close other open applications or files and restart your computer.
17. Go toWindows Control Panel > Administrative Tools > Computer Management. Expand Services and

Applications and select Services.
18. Stop and restart the service SQL Server (SQLEXPRESS).

Post-Installation Configurations
Subsequent to installing SQL Server 2008 and GoldMine, you will need to openMicrosoft Server SQL Management
Studio to confirm (or modify) the configuration of some database settings:

1. Open the WindowsStartmenu and select Programs > Microsoft SQL Server 2008 > SQL Server
Management Studio.

2. In the left panel, clickDatabases to open the folder, then right-click your database, and select Properties.
3. In the Select a page panel, clickOptions.
4. Confirm the Recovery model field is set to Full.

NOTE: This might greatly increase the database size and transaction logs. Transaction logs should
be regulary backed up and truncated to save space.

5. Confirm the Compatibility level field is set to the highest level.
6. In the Automatic section, confirm the Auto Create Statistics is set to True.
7. In the Automatic section, confirm the Auto Update Statistics is set to True.
8. ClickOK.

Troubleshooting
If you receive an error message such asMSSQL Login Failed during the installation of GoldMine, check the following:

■ Is the SQL server running? If not, start SQL Server.
Open the MSSQL Enterprise Manager and find SQL Server Enterprise Manager. Expand the servers until you see
your server name. Right-click your server name and select Start in the local menu.

■ Is the SQL administrative name and password you typed when installing GoldMine different from the name
and password in SQL? Are you using sa with no password, or did you change the password in SQL?
Open the SQL Server Enterprise Manager. ExpandMicrosoft SQL Server and then expand SQL Server Groups.
Right-click your server name and select Edit SQL Server Registration properties. Verify the login name and
password.

■ When you installed SQL, did you select Mixed Mode for the authentication mode?.
If you do not know, go to the server name in the MSSQL Enterprise Manager. ExpandMicrosoft SQL Server and
then expand SQL Server Groups. Right-click your server name and select Properties. Select the Security tab.
Select SQL Server andWindows. Stop and restart SQL Server. The installation continues.



Migrating Large Databases

If you are upgrading from a previous version of GoldMine to version 2015.2 and have a large Microsoft SQL Server
database (5GB of data or more), we recommend you consider the following steps before proceeding with the
upgrade. Certain computers (limited computing power) require manual steps to upgrade the database
successfully.

Database Preparation

Back Up Your Database
This is especially important prior to migration. Also, a power failure or any unpredicted interruptionmay corrupt
data. Invaluable data can be restored from the backup.

Truncate the Transaction Log
For SQL 2008 or SQL 2012

1. From Start, selectMicrosoft SQL Server > SQL Server Management Studio.
2. After logging on to SQL Server, click the New Query toolbar button (or select File > New > Query with

Current Connection).
3. Run:

Alter Database dbname Set Recovery Simple
Alter Database dbname Set Recovery Full

4. Purge the syslog table from your current GoldMine version. Ensure you have backed up your database prior
to purging.

■ To purge logs, select Tools > Logs > GoldMine Logs to open the System Logs dialog. Select either Process
Monitor Logs,Maintenance Logs, or Error Logs. Right-click and select Purge Logs.

■ Select the check boxes for Process Monitor,Maintenance, and Error logs. Accept the default date (1 month)
or adjust to extend. If you require more logs, revise according to the GoldMine Online Help or the GoldMine
Administrator Guide.
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